Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Is Quicken 2015 Compatible with High Sierra?

I have been holding bak on upgrading to High Sierra because of Quicken 2015. I want to be sure it will work before I upgrade and I have not found any answers yet. Anyone?


Thanks

MacBook Air, macOS Sierra (10.12.6), Macbook Air 11 inch, iMac 27 inch

Posted on

Reply
Question marked as Solved
Answer:
Answer:

According to the RoaringApps.com website Quicken 2015 works with High Sierra.


I don't know if Quicken 2015 is a 32 bit or 64 bit application. If it's only 32 then it won't work with the next macOS, 10.14, system which will require only 64 bit apps.

User uploaded file

Posted on

Page content loaded

Question marked as Solved

Nov 14, 2017 1:07 PM in response to Elizabeth Rodriguez In response to Elizabeth Rodriguez

According to the RoaringApps.com website Quicken 2015 works with High Sierra.


I don't know if Quicken 2015 is a 32 bit or 64 bit application. If it's only 32 then it won't work with the next macOS, 10.14, system which will require only 64 bit apps.

User uploaded file

Nov 14, 2017 1:07 PM

Reply Helpful (1)
User profile for user: Elizabeth Rodriguez

Question: Is Quicken 2015 Compatible with High Sierra?