Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How do I use Jabber (or Google) in Messages in OSX .13.1

Up graded to 10.13.1 and now can't message with friends who have a google address.

I tried using my google ID and password in Add Jabber but to no avail. Any work arounds?


Thanks.

iMac (27-inch Mid 2010), OS X El Capitan (10.11)

Posted on

Reply
Question marked as Helpful

Nov 19, 2017 11:49 AM in response to JDB38 In response to JDB38

Hi,


I have my settings at Google for connections by App set to Allow "Less Secure apps"

This is a Google interpretation that anything not using their own Oauth token are not as secure.


I also set the account set up in Internet Account to Automatically find Port and Server



User uploaded file

8:34 pm Saturday; November 18, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Question marked as Helpful

Nov 19, 2017 11:49 AM in response to JDB38 In response to JDB38

HI,


At Google

Login to the Google Web site.

Click on your own Account pic and select Account.

Select security.

It is in the third section "Apps with Account Access".



User uploaded file

7:42 pm Sunday; November 19, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

There’s more to the conversation

Read all replies

Page content loaded

Nov 16, 2017 1:25 PM in response to JDB38 In response to JDB38

Hi,


It now needs to be done fully from System Preferences > Internet accounts

Ignore the Google option as this no longer has the Messages option (It uses a different server which is why it cannot be linked to the Mail login)


Add an Other Account then choose Messages.

You get to choose Jabber and enter your Google ID. (It says you can add AIM but this does not work form the Messages end and AIM are ending the service in December and have done already for client apps like iChat and Messages).


Then go to Messages and the Messages Menu > Status and change it to Available as this make s the window potentially visible

Use the Window Menu which will now include "Buddies"

Changing the Description in Internet Accounts will change it in Messages

User uploaded file

9:25 pm Thursday; November 16, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 16, 2017 1:25 PM

Reply Helpful

Nov 17, 2017 1:11 PM in response to Ralph Johns (UK) In response to Ralph Johns (UK)

Hi Ralph,

Thanks for responding. I did everything you suggested in your note but am still having no success. At the bottom of my list of correspondents, it now says Google where before it said Jabber but as you can see it doesn't make the final connection. Just says connecting but eventually it stops trying to connect. See below:User uploaded file

Any other suggestions?


JDB38

Nov 17, 2017 1:11 PM

Reply Helpful
Question marked as Helpful

Nov 19, 2017 11:49 AM in response to JDB38 In response to JDB38

Hi,


I have my settings at Google for connections by App set to Allow "Less Secure apps"

This is a Google interpretation that anything not using their own Oauth token are not as secure.


I also set the account set up in Internet Account to Automatically find Port and Server



User uploaded file

8:34 pm Saturday; November 18, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 19, 2017 11:49 AM

Reply Helpful (1)
Question marked as Helpful

Nov 19, 2017 11:49 AM in response to JDB38 In response to JDB38

HI,


At Google

Login to the Google Web site.

Click on your own Account pic and select Account.

Select security.

It is in the third section "Apps with Account Access".



User uploaded file

7:42 pm Sunday; November 19, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 19, 2017 11:49 AM

Reply Helpful (1)

Nov 19, 2017 12:05 PM in response to Ralph Johns (UK) In response to Ralph Johns (UK)

User uploaded file for the User uploaded file Points



User uploaded file

8:05 pm Sunday; November 19, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 19, 2017 12:05 PM

Reply Helpful

Nov 20, 2017 8:31 AM in response to Ralph Johns (UK) In response to Ralph Johns (UK)

Ralph,

I've done all of the above instructions and even changed the description to Google Talk. Still no success. It says under Available: Disconnected. I think what I am trying to do is not possible. Thanks for your time and effort.


JDB38

Nov 20, 2017 8:31 AM

Reply Helpful

Nov 20, 2017 1:19 PM in response to JDB38 In response to JDB38

Hi,


IN the Messages Menu have you used the Status item ?

Here you should be able to Select Available to make it Login.


If it is not logging In what are you seeing ?




User uploaded file

9:19 pm Monday; November 20, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 20, 2017 1:19 PM

Reply Helpful

Nov 21, 2017 12:32 PM in response to JDB38 In response to JDB38

Hi,


So...

You have opened an Account in Internet Accounts for a Messages Account for a Jabber ID.


Where the arrow is in this Pic is the ID the exact same as when you login to Google's Web Mail ?

User uploaded file


That is to say Google issued two forms of Names for their Mail service depending where you were in the world.


Some have username@gmail.com and other have username@googlemail.com


Whilst the Apple Mail app seems to be able to use either to get Mail it seems iChat and now Messages have been fussier about this.



User uploaded file

8:32 pm Tuesday; November 21, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 21, 2017 12:32 PM

Reply Helpful

Nov 22, 2017 10:53 AM in response to Ralph Johns (UK) In response to Ralph Johns (UK)

Here is latest. @gmail .com is consistent. Latest clue: If I go into Gmail account and use the text program I can communicate with contact (who is also using Gmail.com on a PC). HOWEVER, when he replies to the text it arrives in bothe places: in my messages window AND the Google app text window. So it seems I am half way there. Can receive but can not send.

Nov 22, 2017 10:53 AM

Reply Helpful

Nov 22, 2017 12:47 PM in response to JDB38 In response to JDB38

Hi,


That's really Odd.


Anyhow try this:-

Quit Messages.

Open Finder window.

Use the Go Menu whilst holding down the ALT key.

This will add the Library to the Menu, select this.

Navigate to Preferences.

Find com.apple.iChat.Jabber.plist

Drag it to the Trash. (it deletes it).


Restart Messages (will recreate the ....Jabber.plist)



User uploaded file

8:47 pm Wednesday; November 22, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 22, 2017 12:47 PM

Reply Helpful
User profile for user: JDB38

Question: How do I use Jabber (or Google) in Messages in OSX .13.1