Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Macbook Pro Sample Rate Problem

Hello Everyone,


I am having a problem with sending and receiving a MIDI signal from my Scarlett Solo/Scarlett 2i2 audio interface(s). When I plug in the interface(s), it is shown in the 'Output' and 'Input' tabs of the sound section in System Preferences and can be selected. However, when I open iTunes or go to Youtube, the song/video will not play (note: I mean it doesn't even play!). So, I go back to the sound section in System Preferences, back to the 'Input'/'Output' tabs, and I change the sample rate of the interface from 44kHz to 96kHz (any other sample rate has the same result as well). Then, I go back to iTunes or Youtube, try to play a song or video, and it works! But, when I open Garageband the sample rate selected goes back! to 44kHz. When I arm the track with Direct Monitoring ON (on the track), and Direct Monitoring OFF (on the interface), click-track enabled, volume on everything -UP, I click play, it counts off and starts rolling... But no sound. Not even a signal is being picked up by the track. Execpt, when I turn Direct Monitoring ON (on the interface(s), I hear my bass with a strong healthy signal. Wut?


Thanks so much! Please feel free to ask any questions...

--

Griffin

MacBook Pro, macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Helpful

Nov 14, 2017 7:16 PM in response to GriffinMyers In response to GriffinMyers

GriffinMyers wrote:



I am having a problem with sending and receiving a MIDI signal


[...]


it is shown in the 'Output' and 'Input' tabs of the sound section in System Preferences and can be selected.


what are you trying to record? you start off asking about MIDI, but then talk about audio; on which type of track are you trying to record? is it a MIDI device or an audio device?


GriffinMyers wrote:


I change the sample rate of the interface from 44kHz to 96kHz

GB only supports a sample rate of 44.1kHz, leave it set at that rate


GriffinMyers wrote:


I click play, it counts off and starts rolling... But no sound. Not even a signal is being picked up by the track.


ok, so i see you're recording an audio signal, not a MIDI signal.


have you selected the 2i2 for input in GB? is an audio track selected for recording?


GriffinMyers wrote:


Execpt, when I turn Direct Monitoring ON (on the interface(s), I hear my bass with a strong healthy signal.


that would be because you're by-passing GB, Direct Monitoring means your hearing the signal you send to the interface right back from the interface. the only obvious things that come to mid are, as stated above, to make sure you've selected your interface in GB's prefs, and are using an audio track:


User uploaded file

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Nov 14, 2017 7:16 PM in response to GriffinMyers In response to GriffinMyers

GriffinMyers wrote:



I am having a problem with sending and receiving a MIDI signal


[...]


it is shown in the 'Output' and 'Input' tabs of the sound section in System Preferences and can be selected.


what are you trying to record? you start off asking about MIDI, but then talk about audio; on which type of track are you trying to record? is it a MIDI device or an audio device?


GriffinMyers wrote:


I change the sample rate of the interface from 44kHz to 96kHz

GB only supports a sample rate of 44.1kHz, leave it set at that rate


GriffinMyers wrote:


I click play, it counts off and starts rolling... But no sound. Not even a signal is being picked up by the track.


ok, so i see you're recording an audio signal, not a MIDI signal.


have you selected the 2i2 for input in GB? is an audio track selected for recording?


GriffinMyers wrote:


Execpt, when I turn Direct Monitoring ON (on the interface(s), I hear my bass with a strong healthy signal.


that would be because you're by-passing GB, Direct Monitoring means your hearing the signal you send to the interface right back from the interface. the only obvious things that come to mid are, as stated above, to make sure you've selected your interface in GB's prefs, and are using an audio track:


User uploaded file

Nov 14, 2017 7:16 PM

Reply Helpful (1)

Nov 14, 2017 4:57 PM in response to GriffinMyers In response to GriffinMyers

try simplifying the set up a bit, ignore the interface...


set GB's prefs to the internal mic, it should be either Built-In Input, or Built-In Microphone


make sure the Audio Track is set to use the Mic for input, and turn Input Monitoring for the track off. Also be sure the Record Level slider is turned up.


do you see a level when you talk?

Nov 14, 2017 4:57 PM

Reply Helpful

Nov 14, 2017 5:32 PM in response to GriffinMyers In response to GriffinMyers

so we know that GB works, and we know the interface works because you can monitor the input from it.


it seems like you have all the settings correct, so the most obvious thing to check now is the cable between the interface and Mac (or possibly the port on the Mac)


try using a different USB cable, and if your Mac has more than one USB port, try using a different port.

Nov 14, 2017 5:32 PM

Reply Helpful
User profile for user: GriffinMyers

Question: Macbook Pro Sample Rate Problem