Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: notes apostrophe problem

Notes Problem


Notes: Why does entering a ' (apostrophe) give me xE2 x80 x99 instead of x27? TextEdit & BBEdit give me x27. grep for ' looks for x27.


Thanks

~VIN,MacBook Pro (17-inch Mid 2010), macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Apparently, I wasn't as thorough as you, and deselecting Edit menu : Substitutions : Smart Quotes now forces a hex 27 for the apostrophe.

Posted on

Question marked as Helpful

Nov 14, 2017 7:29 PM in response to lawrencefromor In response to lawrencefromor

Thank you and just where do I find this "Smart Punctuation"? I know know it is the "preferred" for an apostrophe, but when I select Text, I want Text!

There’s more to the conversation

Read all replies

Page content loaded

Nov 14, 2017 6:12 PM in response to lawrencefromor In response to lawrencefromor

Unless you accidentally input that apostrophe as a right single quotation mark by pressing the key combination shift+option+} on a U.S. keyboard, then Notes is mistaking the apostrophe mark for a UTF-8 right single quotation mark (E2 80 99) character — instead of a proper apostrophe UTF-8 27. Nothing you can do about that except to skip the contraction altogether. Behind that Notes text is HTML code.


Little used, but perhaps even more accurate to the notion of an apostrophe, the modifier letter apostrophe as UTF-8 CA BC looks like this:

User uploaded file

Nov 14, 2017 6:12 PM

Reply Helpful

Nov 14, 2017 6:16 PM in response to lawrencefromor In response to lawrencefromor

lawrencefromor wrote:



Notes: Why does entering a ' (apostrophe) give me xE2 x80 x99 instead of x27?

that could happen if you have Smart Punctuation turned on in system prefs for text or in the app edit menu.

Nov 14, 2017 6:16 PM

Reply Helpful
Question marked as Helpful

Nov 14, 2017 7:29 PM in response to lawrencefromor In response to lawrencefromor

Thank you and just where do I find this "Smart Punctuation"? I know know it is the "preferred" for an apostrophe, but when I select Text, I want Text!

Nov 14, 2017 7:29 PM

Reply Helpful (1)

Nov 14, 2017 8:53 PM in response to lawrencefromor In response to lawrencefromor

In System Preferences : Keyboard panel : Text tab, there is a Use smart quotes and dashes checkbox, and selections for double and single quote styles. Mine is left on, but by unchecking the application's Edit menu : Substitutions : Smart Quotes, then the regular apostrophe that you seek (UTF-8 27) is input, and not the “smart” right single quote (UTF-8 E2 80 99).

Nov 14, 2017 8:53 PM

Reply Helpful
User profile for user: lawrencefromor

Question: notes apostrophe problem