Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Why are my husands calls showing up on my iphone 8

I have a new iPhone 8 and my husband has a 6. We do share an apple ID. After I upgraded, his calls started showing up on my phone and vise versa. I have "Allow calls on other devices" turned off on both phones. Any ideas of what I should do next?

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Because you share the same Apple ID, the call go to both iPhones.


One of you needs to start using another Apple ID.

Posted on

Page content loaded

Nov 14, 2017 5:02 PM in response to buxy67 In response to buxy67

Go to Settings > Phone > Calls on Other Devices and turn that off. You can also check Call Forwarding on both phone and make sure that is also off.


Yes, Allan is right, it's usually a better idea to have separate Apple ID's, but it's not required and I too share an Apple ID with my other half and we have no issues whatsoever doing so.

Nov 14, 2017 5:02 PM

Reply Helpful

Nov 14, 2017 5:14 PM in response to buxy67 In response to buxy67

Look in the iCloud settings. Make sure that you are not sharing the same iCloud account. The check the Facetime settings and make sure that the “You can be reached by FaceTime at“ your phone number is selected in your settings and his phone number is selected in his. Also make sure that the settings are correct in iMessages in the send and receive settings.

Nov 14, 2017 5:14 PM

Reply Helpful
User profile for user: buxy67

Question: Why are my husands calls showing up on my iphone 8