Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I don't have "Use all F1, F2, etc. keys as standard function keys"

I don't have "Use all F1, F2, etc. keys as standard function keys" and the fn key don't work with F keys.


so what to do to have this keys working

iMac, iOS 10.3.3

Posted on

Reply

Page content loaded

Nov 16, 2017 4:12 PM in response to Rashidy In response to Rashidy

Hello Rashidy.

Welcome to Apple Support Communities.

If I'm understanding correctly, functions are not working. I know how this can be an issue and I'll be happy to help.

First, check out the steps below to see if it helps from our article: Change the behavior of function keys on your Mac

You can use the top row of keys on your Apple keyboard as standard function keys or to control built-in Mac features.

If your Apple keyboard has icons printed on some of the keys on its top row, these keys can be used to perform the special features shown in each icon. They can also be used as standard function keys (F1–F12).

The action performed by standard function keys varies depending on the app you're using, or depending on the keyboard shortcuts listed in the Keyboard & Mouse pane of System Preferences:

  • By default, pressing one of these keys performs the special feature indicated by the icon printed on the key. For example, pressing the keys with speaker icons adjusts the volume.
  • If you want to use one of these keys as a standard function key, hold the Fn key (usually in the lower-left corner of the keyboard) while pressing the function key. For example, pressing Fn-F10 (speaker icon) performs the function assigned to the F10 key instead of toggling mute on or off.

If you prefer the top row of keys to always behave as standard function keys without holding the Fn key:

  1. Choose System Preferences from the Apple menu.
  2. Click Keyboard.
  3. Click the Keyboard tab if it's not already highlighted.
  4. Select "Use all F1, F2, etc. keys as standard function keys"

With this option enabled, the keys on the top row act as standard function keys (F1–F12). To use a feature indicated by the icon printed on a key, hold Fn while pressing the key.

After checking these settings and if you are not able to resolve this, reset the NVRAM to see if it helps. Here's how: How to reset NVRAM on your Mac


Cheers.

Nov 16, 2017 4:12 PM

Reply Helpful

Jan 2, 2018 1:24 AM in response to Rashidy In response to Rashidy

I had this same problem on my mid 2012 macbook pro, running Sierra, and using a third party USB keyboard.

I solved it by unplugging the third party keyboard, then rebooting. After the reboot the "Use all F1, F2, etc. keys as standard function keys" button was visible and I checked it. This worked on the macbook pro internal keyboard. I then plugged in the third party USB keyboard, and it still worked, I.e. I could use F6 for step over in xcode, instead of it brightening the screen.

Jan 2, 2018 1:24 AM

Reply Helpful
User profile for user: Rashidy

Question: I don't have "Use all F1, F2, etc. keys as standard function keys"