Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mail constantly 'saving drafts'

Hi


I have an issue with my Apple Mail app on my Retina Macbook Pro. At the bottom left corner where the current activity gets advertised, it constantly says 'Saving 1 of 100 Drafts' with a slightly greyed out Number at the bottom (3.29 GB).

I've tried a rebuild and also deactivated and reactivated my icloud Mail, but nothing helps. In my actual drafts folder in the Mail app there are no drafts at all. Same on my iOS devices and on iCloud.com.


Where can I find these 3.29 GB worth of drafts on my Mac?


I'm not sure if this is also a part of the problem: Whatever I do on my Mac in the Mail app it isn't synced to iCloud nor to any of my iOS devices. Here too: Deactivating and Reactivating the Account does not work.


I somehow think that constant 'Saving 1 of 100 Drafts' is blocking everything.


Cheers


Steve

Posted on

Reply

Page content loaded

Nov 15, 2017 9:02 AM in response to steve diener In response to steve diener

I am assuming that the issue you are having is with your iCloud email account when using the Mail app on your Mac ... correct?


If so, then, let's double-check your Mailbox Behaviors settings to see if anything may be amiss. Below is a screen image of mine. Note that the Drafts Mailbox is set to the iCloud Drafts mailbox and not the On My Mac Drafts mailbox. Is this how yours is configured?

User uploaded file

Nov 15, 2017 9:02 AM

Reply Helpful

Nov 15, 2017 9:28 AM in response to steve diener In response to steve diener

Ok, thanks for clarifying that for me.


The only things that come to mind to check/try, are:

  • Log into Manage your Apple ID with the ID that you use for your iCloud email. Can you log in successfully without any issues?
  • Log into icloud.com with the same Apple ID, using a web browser. Does this issue appear with the Drafts mailbox there?
  • Do you use the same Apple ID on all of your Apple devices ... or do you use multiple IDs?

Nov 15, 2017 9:28 AM

Reply Helpful

Nov 15, 2017 10:08 AM in response to Tesserax In response to Tesserax

No issues login in to iCloud.com or myappleid.com. Everything works fine.


Just noticed: my iPhone, iPad and the icloud.com browser Mail work just fine together. The problem is my Mac that doesn't sync at all.


And those 3.9GB of Drafts are still being saved. Although it doesn't go higher than '1 of 111 Drafts...)

Nov 15, 2017 10:08 AM

Reply Helpful (1)

Nov 15, 2017 10:50 AM in response to steve diener In response to steve diener

The Connection Doctor in Mail says everything's working fine. But I guess the iCloud sync problem lies somewhere else.



User uploaded file

Nov 15, 2017 10:50 AM

Reply Helpful

Nov 15, 2017 10:58 AM in response to steve diener In response to steve diener

And when I export my Drafts Mailbox the Textedit file I get lists quite a lot of drafts, all of which cannot be seen in the active drafts mailbox in the app.

On all my other accounts with empty drafts mailboxes, the corresponding textedit file ist empty aswell.

Nov 15, 2017 10:58 AM

Reply Helpful

Nov 15, 2017 12:51 PM in response to steve diener In response to steve diener

Yes, it looks like everything is fine as far as accessing both the iCloud SMTP & IMAP email servers.


Sorry, the only other thing I can think of is that it may be possible that one or more of your mailboxes is corrupted. This is where re-indexing or rebuilding the mailbox database may help.


Ref: Mail for Mac: Rebuild mailboxes - Apple Support

Nov 15, 2017 12:51 PM

Reply Helpful (1)

Nov 15, 2017 1:00 PM in response to Tesserax In response to Tesserax

Hi Tesserax


Just got the rebuild for my drafts mailbox going. Wonder if that will solve the issue.

I have in the meantime found the folder where all those drafts must be hidden:


(user)/library/mail/v5/(pretty confusing numberswithletters)/drafts.mbox


The folder ist 6 GB big. What if I just discard the drafts.mbox folder here? Wouldn't mail make another, new drafts.mbox folder when I restart it again? That could solve the issue of the constant saving of the drafts?


Cheers


Steve

Nov 15, 2017 1:00 PM

Reply Helpful

Nov 15, 2017 1:11 PM in response to steve diener In response to steve diener

I would suggest the following:

  1. Let the rebuild complete to see if this solves it. If not:
  2. Exit the Mail app if it is running.
  3. Remove the iCloud email account.
  4. Make a copy of drafts.mbox ... just in case.
  5. Go ahead and delete the drafts.mbox as you suggested.
  6. Run the Mail app, and then, add your iCloud email account.

Nov 15, 2017 1:11 PM

Reply Helpful

Nov 15, 2017 11:30 PM in response to Tesserax In response to Tesserax

Hi Tesserax


I let the rebuild finish over night. The message with the 'Saving 1 of 111 Drafts' was gone. Then I deleted the drafts.mbox.


Deleted my sent messages on icloud.com and in the mail app aswell because I saw that there was also quite alot of data stacked there.


Now the syncing works fine again. Read/Unread, deleting or moving mails, everything update pretty quickly again, as it should.


But the 'Saving 1 of 111 Drafts' is here again. Happy everything's syncing again, but somehow I want to get that message away aswell. In the Library where the corresponding drafts.mbox folder is, there's nothing anymore, and I also checked on icloud.com, nothing. So I wonder where this message comes from. Maybe a plist file that still hold the info about those 3.9GB worth of Drafts but the actual data is long erased?


Cheers


Steve

Nov 15, 2017 11:30 PM

Reply Helpful

Nov 16, 2017 12:25 AM in response to steve diener In response to steve diener

So, I think it's done!


I deactivated the mail checkbox in my iCloud settings on my Mac, deleted the whole folder with the icloud mailbox stuff in it in library/mail, then quickly checked the storage that mail was still using (under 'about this mac'). This showed 16 GB at first, then changed to 16 MB.


Then I reactivated mail in the iCloud settings. Reopened the Mail app, and the message is gone. Everything fine now, hope it stays that way!


Thanks for the help.


Cheers


Steve

Nov 16, 2017 12:25 AM

Reply Helpful (2)
User profile for user: steve diener

Question: Mail constantly 'saving drafts'