Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Since High Sierra 10.13.01 on my MacPro, I can't seem to sync iMessages to all my devices. Help please.

I used to sync iMessages to all my devices (iPad, iPhone, and MacPro). Since upgrading, the syncs have gone bad, especially to/from MacPro desktop. Can someone tell me the correct settings to use on each of these three?


Many thanks,


Czet

Posted on

Reply

Page content loaded

Nov 16, 2017 1:34 PM in response to Czet In response to Czet

Hi,

Test.

ON the iPhone in Settings > Messages restrict the Send and Receive to just the iPhone Number (you don't need to Sign Out of the Apple ID just set so it is not active.


DO the reverse on the Mac in Preferences > Accounts for the iMessages Account except Allow the Apple ID and not the iPhone Number.


So now the iPhne can only receive item addressed to the iPhone Number and the Mac only items addressed to the Apple ID.


On the Mac start an New Messages and manually add the iPhone Number including Country Code to the "To" spot (if you type in your Name it will not call up the My Card from Contacts).


Send an iMessage to the iPhone.

If it does not go or does not arrive then you need to go here When the iMessages account will not Login


If it worked re-enable the deactived IDs on each device.




User uploaded file

9:34 pm Thursday; November 16, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 16, 2017 1:34 PM

Reply Helpful
User profile for user: Czet

Question: Since High Sierra 10.13.01 on my MacPro, I can't seem to sync iMessages to all my devices. Help please.