Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: imac photo: not working

I am running an imac mid-2010 on High Sierra.

I can see the "photo" app icon but it is not responding. WHen I try to drop photos on to the icon , there is no response.

I have checked for updates but to no avail.


Any suggestions as to what I have "broken!????

iMac, iOS 10.3.3

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

First restart the computer and re-try.


If that fails, restart the computer in Safe Mode and attempt to open Photos.


If that fails, then restart normally, create a new user account (call it TEST Account) and see if the Photos app opens. If it does you likely have a corrupt database. In that case follow the directions in Use the Photos library repair tool - Apple Support

Posted on

Page content loaded

Question marked as Apple Recommended

Nov 15, 2017 11:57 AM in response to feemackenzie In response to feemackenzie

First restart the computer and re-try.


If that fails, restart the computer in Safe Mode and attempt to open Photos.


If that fails, then restart normally, create a new user account (call it TEST Account) and see if the Photos app opens. If it does you likely have a corrupt database. In that case follow the directions in Use the Photos library repair tool - Apple Support

Nov 15, 2017 11:57 AM

Reply Helpful
User profile for user: feemackenzie

Question: imac photo: not working