Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Application stuck in install loop

I have purchased an application from the App store. It shows in App Store under "Purchased".

The button next to it says "Install".

Clicking Install commences the download, and everything looks to be going fine.
The download completes, but the application never installs. The Install button is initially greyed out but if you click on it again the download commences again.
I have another similar version of this app direct from the developer, so it is possible that it won't allow two installs of the same app? (even though they are not strictly identical).
I have tried renaming the other app and even moving the other version into a partition and using Spotlight > Privacy to stop searching that drive for the other version.
How do I convince the App Store to complete the install process?

iMac, macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Close down all apps and restart. Try again.


Late 2012 Mac mini, macOS 10.13.1;  Watch S3, watchOS 4.1; iPad Air 2 & iPhone 6+, iOS 11.1; TV 4th Gen, tvOS 11.1;  Airport Express

Posted on

Page content loaded

User profile for user: thilliam

Question: Application stuck in install loop