Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Watch app crashes on iPhone X

I have a Gen 1 Apple Watch. I just set up my iPhone X (from my iPhone 6 backup) and all appears to be working except the Watch app on the iPhone X crashes on open. During the set up process I was able to pair the watch successfully and it appears to be communicating with the iPhone X. I just can't get the Watch app to open.


I have tried restarting the iPhone X to no avail. When I long-press the Watch app, I see the "Pair Apple Watch" popup, but if I tap it, the app crashes.


Has this been happening to anyone else? Any suggestions for fixing this?

Posted on

Reply

Page content loaded

Nov 16, 2017 7:56 AM in response to caf In response to caf

my bad. I'm so used to whatsapp going bat****crazy I saw whatsapp

Dyslexia 2, Jimmy 0


see this article for removing the watch app

Delete built-in Apple apps on your iOS 11 device or Apple Watch - Apple Support

then restore the app


failing that see this article

Reset your iOS device to factory settings - Apple Support

Nov 16, 2017 7:56 AM

Reply Helpful

Dec 19, 2017 3:31 PM in response to caf In response to caf

I have tried to uninstall and reinstall the watch app. I rebooted. My watch is no longer usable since I reset it and is waiting to pair. I’ve waited for operating system updates hoping that would fix it but it has not. I hope it will start working as I’m sure the next recommendation is tp reinstall my phone from a reset which I am hoping I can avoid.

Dec 19, 2017 3:31 PM

Reply Helpful
User profile for user: caf

Question: Watch app crashes on iPhone X