Related Article

What to do before you sell, give away, or trade in your Mac

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Make my macbook air stop copying everything on my iMac

My macbook air has files copied from my iMac; when I delete a file on the Air, it disappears on the iMac. I don't want or need, or have room, on my laptop for files I use only on my desktop. Both systems are running High Sierra.

IMAC (RETINA 5K, 27-INCH, LATE 2015), macOS High Sierra (10.13.1)

Posted on

Reply

Page content loaded

Nov 16, 2017 10:08 AM in response to Wimustapplesuck In response to Wimustapplesuck

Open System Preferences and select iCloud. Do you have a checkmark next to iCloud drive on both computers? If so, this automatically moves your files from the selected folders and puts them in your iCloud account. Also, anything that is synced to the cloud will then copied from the cloud to your other computers.


Solution 1: turn off iCloud drive on your MBA

Solution 2: turn iCloud drive on but then click on the options button and select only specific folders to sync. The first item is Desktop and Documents folders which is the one you've noticed causing trouble. If there are some files you keep in the Documents folder of your desktop that you'd like to sync but others you don't want to sync with the MBA you can create a folder in your user directory on the desktop for storing what you don't want synced.

Nov 16, 2017 10:08 AM

Reply Helpful

Nov 16, 2017 10:53 AM in response to dwb In response to dwb

Sorta helped, but I found it easier to just uncheck Desktop and Documents completely, and restore the MBA files by external drive. Thanks for the suggestion. By the way, I have no idea why my id is Wimustapplesuck, it's not something I originated. (If I had, it would have been Wimusticloudbesoaggravating.)

Nov 16, 2017 10:53 AM

Reply Helpful
User profile for user: Wimustapplesuck

Question: Make my macbook air stop copying everything on my iMac