Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Links on Mail not working on chrome

Whenever I click a link on Mail it opens a new tab instead of the link itself. I tried switching default browsers between safari and chrome but that didn't work (someone suggested in a another thread)


Suggestions?

Posted on

Reply

Page content loaded

Nov 30, 2017 7:18 AM in response to Kaleido37 In response to Kaleido37

I have this question too. I see this on my MacBook Air 2013 model, running High Sierra 10.13.1.

And using Chrome Version 64.0.3277.0 (Official Build) canary (64-bit).

I upgraded to High Sierra just a day or two ago. I cannot definitively tie it to the OS upgrade, but its likely.

I click on a link in Apple Mail Version 11.1 (3445.4.7). It opens a new Chrome window, but does not follow the link, and so the browser page remains blank. [Thurs Nov 30 2017]


Nov 30, 2017 7:18 AM

Reply Helpful

Nov 30, 2017 7:59 AM in response to pvdl10 In response to pvdl10

pvdl10 wrote:


Bob's suggestion worked, and restored the functionality of links in email.

The current rev of Chrome is: Version 64.0.3281.0 (Official Build) canary (64-bit)

Thank you heartily, Bob.


Glad it's working but Canary is the developer build of Chrome.

Nov 30, 2017 7:59 AM

Reply Helpful
User profile for user: Kaleido37

Question: Links on Mail not working on chrome