Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I don't want the emoji viewer icon automatically in the menu bar

Hi

Glance down to get to the short story.


I just changed to Apple. I want to like my apple products, and I do. But there are surprisingly many small issues that ought to be obvious that annoys me. I sent a few to the Apple feedback, but I feel that is overkill so I came here to vent instead. Someone is stupid, I hope it is me.


In this post I will limit my rant to the latest annoying thing.

Not all symbols are shown on the Apple keyboard, that is fine, it makes the keyboard prettier, I accept and even like that. I have enabled "Settings/Keyboard/Input sources/Show input menu in menu bar" which shows a pretty flag in the menu bar that I can click to find hidden symbols.


Short story starts here.

Whenever I bring up the emoji viewer with control+command+space the pretty flag is automatically replaced with an ugly emoji viewer icon. To remove that icon I have to go to settings.

I do not want the emoji viewer icon automatically in the menu bar!


Best regards

Patrik

iMac, macOS High Sierra (10.13.1), 2017 iMac

Posted on

Reply
Question marked as Helpful

Nov 16, 2017 11:48 AM in response to patrik_t In response to patrik_t

All the symbols needed will be displayable using the Keyboard Viewer. However, as of now, you cannot disable the Emoji viewer without disabling the entire menubar item. But that does not mean you need to use it. If you don't want anything in the item then disable it where you enabled it or hold down the COMMAND key then drag the menubar icon out of the menubar.


Your posts can only be edited within 15 minutes of the posting time. After that, you cannot make changes.

There’s more to the conversation

Read all replies

Page content loaded

Nov 16, 2017 11:17 AM in response to patrik_t In response to patrik_t

ALERT!! No rants, gripes, complaints, and vents are permitted on the forums. See the Apple Support Communities - Terms of Use. If you have a legitimate problem with which you need help then post just your problem. Read Writing an effective Apple Support Communities question.

Nov 16, 2017 11:17 AM

Reply Helpful

Nov 16, 2017 11:29 AM in response to Kappy In response to Kappy

I am sorry.

I tried to edit the post but was not allowed.


Hi

Glance down to get to the short story.


Not all symbols are shown on the Apple keyboard, that is fine, it makes the keyboard prettier, I like that. I have enabled "Settings/Keyboard/Input sources/Show input menu in menu bar" which shows a pretty flag in the menu bar that I can click to find hidden symbols.


Short story starts here.

Whenever I bring up the emoji viewer with control+command+space the pretty flag is automatically replaced with an emoji viewer icon. To remove that icon I have to go to settings.

I do not want the emoji viewer icon automatically in the menu bar.

How can I solve this?


Best regards

Patrik

Nov 16, 2017 11:29 AM

Reply Helpful
Question marked as Helpful

Nov 16, 2017 11:48 AM in response to patrik_t In response to patrik_t

All the symbols needed will be displayable using the Keyboard Viewer. However, as of now, you cannot disable the Emoji viewer without disabling the entire menubar item. But that does not mean you need to use it. If you don't want anything in the item then disable it where you enabled it or hold down the COMMAND key then drag the menubar icon out of the menubar.


Your posts can only be edited within 15 minutes of the posting time. After that, you cannot make changes.

Nov 16, 2017 11:48 AM

Reply Helpful (1)

Nov 16, 2017 11:48 AM in response to Kappy In response to Kappy

Thanks

I like the no negativity policy, sorry I violated it, I was a bit wound up. Maybe an admin can remove my bad post.

Should I mark the issue solved?

Your post is the answer to what is possible but it does not really solve my problem.

Nov 16, 2017 11:48 AM

Reply Helpful

Nov 16, 2017 12:36 PM in response to patrik_t In response to patrik_t

If your problem is not solved then don't mark it so. Normally, when you use the Solved reward it would be the answer that solved the problem. For example, you rewarded my answer as Helpful. Had you considered it did solve your problem then you would have rewarded it Solved instead of Helpful.


Unfortunately, the solution you would like is not available. Nevertheless, the viewers never appear unless you select one. Otherwise, they just remain in the context menu for the menubar item with the nice flag. 😀

Nov 16, 2017 12:36 PM

Reply Helpful
User profile for user: patrik_t

Question: I don't want the emoji viewer icon automatically in the menu bar