Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Disable Open Link Behind Mail in High Sierra

Since installing High Sierra by default whenever I click a link in a Mail message it automatically opens the browser window behind the Mail window. How do I turn that off so the browser window opens on top?

iMac

Posted on

Reply
Question marked as Solved
Answer:
Answer:
Hello and welcome to Apple Support Communities pinner123,

I see that you're having an issue when clicking on a link in an email that the brower window opens up behind your Mail window. I'd be happy to look into this with you, and see if we can get this resolved for you quickly.

Do you happen to be holding down the Command key on the keyboard when you click the links? That keyboard shortcut, by design, opens a browser window behind your current window (in this case, Mail).

If not, then let's start by having you start the iMac into safe mode and test to see if the issue remains in safe mode:

Use safe mode to isolate issues with your Mac

If after testing in safe mode the issue still remains, let's try and test on another user account and see if the issue persists:

How to test an issue in another user account on your Mac

Let me know how this goes.

Thank you for using Apple Support Communities.

Have a great day.

Posted on

Page content loaded

Question marked as Solved

Nov 20, 2017 2:02 PM in response to pinner123 In response to pinner123

Hello and welcome to Apple Support Communities pinner123,

I see that you're having an issue when clicking on a link in an email that the brower window opens up behind your Mail window. I'd be happy to look into this with you, and see if we can get this resolved for you quickly.

Do you happen to be holding down the Command key on the keyboard when you click the links? That keyboard shortcut, by design, opens a browser window behind your current window (in this case, Mail).

If not, then let's start by having you start the iMac into safe mode and test to see if the issue remains in safe mode:

Use safe mode to isolate issues with your Mac

If after testing in safe mode the issue still remains, let's try and test on another user account and see if the issue persists:

How to test an issue in another user account on your Mac

Let me know how this goes.

Thank you for using Apple Support Communities.

Have a great day.

Nov 20, 2017 2:02 PM

Reply Helpful
User profile for user: pinner123

Question: Disable Open Link Behind Mail in High Sierra