Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Setting up homekit with a wireless access point

I live in a two story house. We have a router on the main floor and a wireless access point upstairs.


I recently set up a smart light switch on the main floor and it is connected to the router. When I am on the main floor, my iPhone is connected to the router and I can manage the light switch through homekit. However, when I am upstairs, my phone automatically connects to the access point and the status of the light switch changes to "no response ".


I am assuming that this is because when I am upstairs, I am on a different network than the light switch. Is there a way I can set up homekit or my wireless access point so I can seamlessly use homekit to manage the light switch no matter where I am in my house?

Posted on

Reply

Page content loaded

Nov 17, 2017 7:54 AM in response to MrSandhar In response to MrSandhar

Hi. Are you actually on a different network when connected to the AP?. Is the second-last number (xxx) in the IP address (*.*.xxx.yyy) different? If it is, you should change the configuration of the AP to be a pure AP, with all DHCP being managed by the main router. This assumes that your AP is connected by ethernet cable to the router.

Nov 17, 2017 7:54 AM

Reply Helpful

Nov 17, 2017 11:15 AM in response to Diana.McCall In response to Diana.McCall

Hi Diana, my AP is connected by ethernet cable to the router.Yes, I am on a different network when connected to the AP. When I check wifi settings in my iPhone, there are different IP addresses when I am connected to the router and AP. Additionally, if I turn off the AP my iPhone connects to the router and I can manage my smart light switch perfectly, no matter where I am in the house.


I am using a D-Link DAP 1650 range extender, configured as an access point. How can I change it so all DHCP are being managed by the main router?

Nov 17, 2017 11:15 AM

Reply Helpful

Nov 17, 2017 2:05 PM in response to Diana.McCall In response to Diana.McCall

I seem to have found the root of the issue. My internet provider has installed a modem/router which has an ip address of 192.168.1.254. However, I do not use this as a router and have installed my own router that has an ip address of 192.168.0.1.


I have now set up the access point as a bridge, disabled DHCP and given it the static ip address of 192.168.0.2. However, in my iPhone's wifi settings, the router ip address is 192.168.1.254 (of my isp's modem/router).


I think I will have to set up both my router and access point as bridges and give them static ip address of 192.168.1.1 and 192.168.1.2. Does that seem correct?


Thanks.

Nov 17, 2017 2:05 PM

Reply Helpful

Nov 17, 2017 3:36 PM in response to MrSandhar In response to MrSandhar

SOLVED: I ended up turning off my router and using the router provided by the ISP. Now the IP addresses on the router and access point match and I can seamlessly use home kit throughout my house.

Nov 17, 2017 3:36 PM

Reply Helpful
User profile for user: MrSandhar

Question: Setting up homekit with a wireless access point