Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mail drafts not saving

I'm having a problem with Mail, using OS Sierra (10.12.6), Mail 10.3 and gmail. It's no longer saving drafts of my emails. I'll compose an email, then want to save it as a draft - so click Save on the "Save as draft?" dialogue....then - nothing. Nothing in my draft folder.


Actually, nothing in *either* of my draft folders, as there are two. One is under "Mailboxes" - along with VIPs, Sent, Junk, Trash and All Mail. The other is under "On My Mac" with just one other folder, Recovered Messages. Both folder names are followed by the name of my gmail account, so looks like this: Drafts (gmailname).


The gmail drafts folder does have a few drafts from a few months ago, back when this was working. The other has nothing in it. I'd like to be able to retrieve drafts from other devices, so whichever folder would enable that is preferred.


I did switch computers about a month ago, from a MacBook Pro running OS X Yosemite (10.10.5) to a Mac mini running Sierra. Can't say for sure that's when this started, but it's possible (maybe likely).


One other thing: in other strings on similar problems, there was advice about the ensuring drafts were saved on server in Preferences. I don't see that option anymore in Preferences. Here's what I got:


User uploaded file


Any help would be appreciated. Thanks.

Mac mini, macOS Sierra (10.12.6), Mac mini late 2014

Posted on

Reply
Question marked as Solved
Answer:
Answer:

That worked - "show in IMAP" was not checked for Drafts. I checked that and all is well now. Thank you!

Posted on

Question marked as Helpful

Nov 17, 2017 9:00 AM in response to phd67 In response to phd67

Open web mail account ( gmail ) by entering web mail address and password , click on gear icon > settings > Labels .

The default settings are .

User uploaded file

User uploaded file

Did you changed these settings or created some filters ?

As what ever settings are changed on the web mail account the settings will have immediate impact on apple mail application , avoid using mail butler or some unwanted apps , cleaners , anti virus in the system .

There’s more to the conversation

Read all replies

Page content loaded

Nov 17, 2017 7:59 AM in response to phd67 In response to phd67

Try rebuilding the mailbox.


Rebuild mailbox


If that doesn't work, try re-indexing the mailboxes. This can take awhile if you have a lot of mail.


Reindex messages For El Capitan, try looking in V3. Sierra use V4. High Sierra use V5.


Reindex messages (2) See post by Linc Davis

Nov 17, 2017 7:59 AM

Reply Helpful
Question marked as Helpful

Nov 17, 2017 9:00 AM in response to phd67 In response to phd67

Open web mail account ( gmail ) by entering web mail address and password , click on gear icon > settings > Labels .

The default settings are .

User uploaded file

User uploaded file

Did you changed these settings or created some filters ?

As what ever settings are changed on the web mail account the settings will have immediate impact on apple mail application , avoid using mail butler or some unwanted apps , cleaners , anti virus in the system .

Nov 17, 2017 9:00 AM

Reply Helpful (1)
User profile for user: phd67

Question: Mail drafts not saving