Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Cannot connect to WiFi with OS High Sierra

Since “upgrading” to High Sierra I have been unable to connect my MacBook Air to WiFi or a personal hotspot using my ATT U-Verse router. I find this to be curious because I am able to connect my IPhone 6 and my iPad 4 with no issues.


Is this a known problem with the new release?

MacBook Air (13-inch, Early 2015), macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hi,


I'm an IT architect, and I've had the same exact problem with AT&T U-Verse. I've shared the solution I've found to solve the problem, hopefully they'll make sense to a larger non-technical audience and work for them as well. These instructions should work with any version of Mac OS, as it is not a Mac-related issue directly. It is a router configuration problem with the "enhanced" technology.


The Problem:


Some Apple devices have trouble connecting to AT&T U-Verse router/gateway (router), although other devices connect without incident. In many cases, other Apple devices connect just fine (iPhone/iPad etc.).


The AT&T U-Verse wireless routers come pre-configured with “Enhanced” WiFi technology enabled. This technology is for optimizing wireless connections. This causes a problem for MacBooks of various flavors.


The Solution - Overview:


Disable this feature by making sure the 2.4 GHz and 5 GHz network names are “different”. The passwords can be the same if you wish.


You’ll need the log in credentials for your U-Verse router (on the bottom of the device). I took a photo of this information to make it easier to see these details while working in a more convenient place away from the router—like the kitchen table or some other more suitable place near the router.


The Specific Fix:


Access the settings configuration web page on the router by following the established process for connecting to the router via the admin console using an internet browser. I accessed the admin interface on the router using http://192.168.1.254 (also located on the bottom of the router) from any other device with a properly working internet connection on my network.


After successfully logging into the U-Verse router, you’ll land on the Home Page tab. Click the Wi-Fi link to access the wireless settings.


You’ll see the following, regarding the “enhanced” feature, which I’ve determined is the cause of the problem for MacBooks:


Warning: Your 2.4 GHz and 5 GHz network names and passwords must match to benefit from the enhanced Wi-Fi technology on your gateway.


Your device is equipped with enhanced Wi-Fi technology, known as band steering, that is designed to provide improved in-home Wi-Fi performance by automatically optimizing the connection for each of your in-home Wi-Fi devices. For this technology to work properly and provide you with optimized Wi-Fi performance, the Wi-Fi network name (SSID) and password for both the 2.4GHz and 5GHz Wi-Fi radios in this Wi-Fi Gateway must match.


Creating unique network names and passwords for the 2.4GHz and 5GHz radios will disable the optimization feature and potentially result in degraded in-home Wi-Fi performance.


For more information go to att.com/enhancedwifi


Make sure the WiFi names are “different”—the fix. In my case, I just added the number 5 as the last character of my 5 GHz network so I can see which it is on my WiFi list when choosing a network to join. Once changed, save settings and restart the router.


Disabling this enhanced feature hasn’t affected the quality of other devices on my network in any noticeable way, and as such, is worth it in my case to disable this feature to ensure my MacBook can access the network and therefore, the internet. These changes can always be reversed should any challenges arise.


If this is done properly, you’ll be able to choose between your 2.4 GHz and 5 GHz networks on any of your devices, as your 5 GHz network will be the one with the “5” at the end—your visual indicator.


Once completed, the MacBook should be able to connect to the router wirelessly.


Conclusion:


I haven't noticed any adverse connectivity issues among the many other manufacturers/Apple Computer devices connecting to my network that warrants having this “Enhanced” feature enabled therefore, preventing MacBooks from connecting.


If you still have connectivity challenges (especially using the 5 GHz network), try connecting your MacBook to various 5GHz “channels”, until you find one that works, or join your 2.4GHz network instead. This can be helpful with older MacBooks.


The 5 GHz network has faster throughput over “shorter” distances compared to the 2.4 GHz network, which offers slower throughput over “longer” distances comparatively.


If this doesn’t make sense, or you’re having trouble, find one of your tech-friends. If they know anything about configuring WiFi at home, they’ll find these instructions very basic, absent A-B-C,1-2-3 instructions with screenshots 🙂


Good luck!

Posted on

Page content loaded

Nov 18, 2017 2:48 PM in response to gresfordt In response to gresfordt

Hello gresfordt,

After reviewing your post, it sounds like you are having trouble connecting your MacBook Air to a Wi-Fi network or a personal hotspot. It looks like you have isolated this to the MacBook Air since two iOS devices are not affected. I would recommend you read these articles and use them to help troubleshoot the issue.

Check for Wi-Fi issues using your Mac

How to troubleshoot Wi-Fi connectivity
Recommended settings for Wi-Fi routers and access points

Thank you for using Apple Support Communities. Have a nice day.

Nov 18, 2017 2:48 PM

Reply Helpful
Question marked as Solved

Jan 4, 2018 8:38 AM in response to gresfordt In response to gresfordt

Hi,


I'm an IT architect, and I've had the same exact problem with AT&T U-Verse. I've shared the solution I've found to solve the problem, hopefully they'll make sense to a larger non-technical audience and work for them as well. These instructions should work with any version of Mac OS, as it is not a Mac-related issue directly. It is a router configuration problem with the "enhanced" technology.


The Problem:


Some Apple devices have trouble connecting to AT&T U-Verse router/gateway (router), although other devices connect without incident. In many cases, other Apple devices connect just fine (iPhone/iPad etc.).


The AT&T U-Verse wireless routers come pre-configured with “Enhanced” WiFi technology enabled. This technology is for optimizing wireless connections. This causes a problem for MacBooks of various flavors.


The Solution - Overview:


Disable this feature by making sure the 2.4 GHz and 5 GHz network names are “different”. The passwords can be the same if you wish.


You’ll need the log in credentials for your U-Verse router (on the bottom of the device). I took a photo of this information to make it easier to see these details while working in a more convenient place away from the router—like the kitchen table or some other more suitable place near the router.


The Specific Fix:


Access the settings configuration web page on the router by following the established process for connecting to the router via the admin console using an internet browser. I accessed the admin interface on the router using http://192.168.1.254 (also located on the bottom of the router) from any other device with a properly working internet connection on my network.


After successfully logging into the U-Verse router, you’ll land on the Home Page tab. Click the Wi-Fi link to access the wireless settings.


You’ll see the following, regarding the “enhanced” feature, which I’ve determined is the cause of the problem for MacBooks:


Warning: Your 2.4 GHz and 5 GHz network names and passwords must match to benefit from the enhanced Wi-Fi technology on your gateway.


Your device is equipped with enhanced Wi-Fi technology, known as band steering, that is designed to provide improved in-home Wi-Fi performance by automatically optimizing the connection for each of your in-home Wi-Fi devices. For this technology to work properly and provide you with optimized Wi-Fi performance, the Wi-Fi network name (SSID) and password for both the 2.4GHz and 5GHz Wi-Fi radios in this Wi-Fi Gateway must match.


Creating unique network names and passwords for the 2.4GHz and 5GHz radios will disable the optimization feature and potentially result in degraded in-home Wi-Fi performance.


For more information go to att.com/enhancedwifi


Make sure the WiFi names are “different”—the fix. In my case, I just added the number 5 as the last character of my 5 GHz network so I can see which it is on my WiFi list when choosing a network to join. Once changed, save settings and restart the router.


Disabling this enhanced feature hasn’t affected the quality of other devices on my network in any noticeable way, and as such, is worth it in my case to disable this feature to ensure my MacBook can access the network and therefore, the internet. These changes can always be reversed should any challenges arise.


If this is done properly, you’ll be able to choose between your 2.4 GHz and 5 GHz networks on any of your devices, as your 5 GHz network will be the one with the “5” at the end—your visual indicator.


Once completed, the MacBook should be able to connect to the router wirelessly.


Conclusion:


I haven't noticed any adverse connectivity issues among the many other manufacturers/Apple Computer devices connecting to my network that warrants having this “Enhanced” feature enabled therefore, preventing MacBooks from connecting.


If you still have connectivity challenges (especially using the 5 GHz network), try connecting your MacBook to various 5GHz “channels”, until you find one that works, or join your 2.4GHz network instead. This can be helpful with older MacBooks.


The 5 GHz network has faster throughput over “shorter” distances compared to the 2.4 GHz network, which offers slower throughput over “longer” distances comparatively.


If this doesn’t make sense, or you’re having trouble, find one of your tech-friends. If they know anything about configuring WiFi at home, they’ll find these instructions very basic, absent A-B-C,1-2-3 instructions with screenshots 🙂


Good luck!

Jan 4, 2018 8:38 AM

Reply Helpful (4)

Nov 27, 2017 11:50 AM in response to ErvDoggie In response to ErvDoggie

Hi, thanks for that advice. Made absolute sense. So I tried it with my BT router (I’m in the UK) which seemed to get me a step closer in that my macbook air now tells me I have a connection and an IP adress (which is further than it got before when I kept getting ’you are conected but no IP address). But now if I try to access any webpage it just seems to start the load and then freeze almost immediately (i.e. little blue loading lines creeps along for a fraction then just stops). Any ideas where I go from here? (Tried on both 2.4 and 5). Cheers

Nov 27, 2017 11:50 AM

Reply Helpful (2)
User profile for user: gresfordt

Question: Cannot connect to WiFi with OS High Sierra