Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Icons missing

With the update of iOS 10.13.1 , the applications, as well as many others has had the icon not present. The application itself works just fine and I know there is no malware or viruses present since I have already checked.

This has been happening multiple times as I've fixed it by removing from my doc then putting them back as they were before.

What is exactly happening with my computer? Why does this happen? and what can I do to prevent this from happening any more in the future?


User uploaded file

MacBook Air (13-inch, Early 2015)

Posted on

Reply

Page content loaded

Nov 18, 2017 8:40 AM in response to KelsRCola In response to KelsRCola

Try doing a Dock restart using the following Terminal command:


killall Dock


Log out/in and test. If that doesn’t work, you need to look in your user Library/Application Support/Dock for the .db. Use the Finder “Go To Folder” command. Enter ~/Library/Applications Support/Dock. Move the .db to your desktop.


Then try a dock reset.


Applications/Utilities/Terminal enter the command


killall Dock


Log out/in test. If it works okay, delete the .db from the desktop.


If the Dock is the same, return the .db to where you got them from, overwriting the newer ones.


If you prefer to make your user library permanently visible, go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Learned from leonie.

Nov 18, 2017 8:40 AM

Reply Helpful
User profile for user: KelsRCola

Question: Icons missing