Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I constantly get safari-icons on screen when clicking links

Since my update to MacOS High Sierra, I constantly get these safari icons on my screen (screenshot) when clicking links. User uploaded file


Is this a bug or some kind of plugin? I find this very annoying and would like a way to disable this. Anyone?

iMac with Retina 5K display, macOS High Sierra (10.13.1)

Posted on

Reply

Page content loaded

Nov 18, 2017 5:23 AM in response to Dvdesign In response to Dvdesign

Safari 11



Turn “Handoff” on and test.


Turn Handoff on or off

On your Mac: Choose Apple menu > System Preferences, click General, then select “Allow Handoff between this Mac and your iCloud devices” (below “Recent items”). To turn it off, deselect the option.


About Handoff:


https://support.apple.com/en-us/HT204681

https://support.apple.com/kb/PH25169?locale=en_US

Nov 18, 2017 5:23 AM

Reply Helpful
User profile for user: Dvdesign

Question: I constantly get safari-icons on screen when clicking links