Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Macbook Pro won't boot after installing High Sierra

I installed High Sierra on my Macbook Pro and it seemed to go fine until the last step when it was restarting the computer. There was a long wait where a load bar indicated the status of the install. That finished and then the system tried to reboot. The load bar filled to 100% but never gave me the login page and I haven't been able to get past black screen with the apple icon and load bar since then.


Things that I've tried so far that haven't worked:

1) Recovery Mode-- the system does not give me disk utility when I try to use recovery mode, I just go straight to the apple icon and load bar

2) Internet Recovery Mode-- I get the globe and when that finishes, instead of giving me disk utility it sends me straight to the apple icon and load bar

3) Safe Mode-- goes straight to apple icon and load bar

4) Reset NVRAM-- reset works, but I still get stuck on loading screen

5) SMC reset-- I still get stuck on loading screen

6) Running fsck from single user mode-- it says that the disk seems OK but I still can't boot

7) Choosing my drive from the startup manager-- doesn't boot, when using startup manager the only option is my mac HD disk


Errors that seem weird when I start in single user mode:

disk1s1: device is not readable

disk1s1: IO failed, error = 13

hfs_mountfs: buf_meta_bread failed with 13

hfs_mount: hfs_mountfs returned error=13 for device unknown-dev

hfs_mountroot failed: 13

....

er_state_obj_get_for_recovery:36883:No ER state object -rolling is not happening, nothing to recover.

...

apfs_vfsop_mount:1272: failed to retreive boot-manifest-hash

....

(there is more, but I'm not sure which parts are the most helpful so I will stop here.

I haven't tried re-installing OS from a USB because I don't own one


If anyone has experience with this issue and knows a fix, please let me know!

Thanks for reading this clunky and un-informed post. Any suggestions are appreciated.

Peggy 🙂

MacBook Pro with Retina display, macOS High Sierra (10.13.1)

Posted on

Reply

Page content loaded

Nov 18, 2017 3:01 PM in response to margarettajune In response to margarettajune

Hey margarettajune,

If I understand correctly, your MacBook Pro will not boot to the desktop. It looks like you have already done a good amount of troubleshooting. Since Recovery Mode and Internet Recovery are not working and you get a disk not readable error, you may want to consider contacting an ARS or AASP. I would recommend you read this article and use it to help troubleshoot the issue.

Mac Service Answer Center


Thank you for using Apple Support Communities. Have a good one.

Nov 18, 2017 3:01 PM

Reply Helpful

Nov 18, 2017 3:21 PM in response to joe_7399 In response to joe_7399

joe_7399


Please do not use acronyms when answering User's queries. You are supposed to be the answer guy. Type out whatever you mean, not "ARS" and "AASP", no matter how many extra characters it takes you -- the people you are purporting to help do not necessarily share your jargon and TLAs, and may not even be native speakers of English. Even gratuitous use of Pronouns can be a problem -- you really need to spell it all out and always use Nouns, even if it make the sentence awkward.

Nov 18, 2017 3:21 PM

Reply Helpful

Nov 20, 2017 8:21 PM in response to margarettajune In response to margarettajune

I get exactly the same message running verbose mode after attempting to install High Sierra. This was an upgrade from Sierra through Application manager. I can still boot into recovery and my partitioned Bootcamp disk tho.


Since then i've tried multiple times to reinstall through internet recovery. My main HD is now coming up as APFS and i can browse files through terminal so it would appear the drive is readable when accessed through the High Sierra Installer. I've also created a bootable USB drive with the installer, this produces the same results.


The only thing i could think of that might be the cause is the firmware update - i heard that it should have occured when the machine restarted but it wasn't something i observed (no beep, no flashing power light). I suppose its possible that has already been installed, but I'm not finding an easy way to check which firmware I'm now running. Any help would be appreciated



Rob

Nov 20, 2017 8:21 PM

Reply Helpful

Dec 9, 2017 6:27 PM in response to margarettajune In response to margarettajune

Not sure if this will help anyone but here goes. I had this identical issue, except mine is a Mid-2012 MacBook Air. Last thing I had done was install Little Snitch V4.0.4. Upon reboot, it hung.


In verbose mode, every error you listed, I had - precisely. Verbose mode also hung at random points. It wasn't consistent. Safe mode didn't seem to work for me. So I restarted in single user mode and ran fsck - it said my disk seemed okay. When I exited single user mode, I immediately entered recovery mode by holding Command+R after the startup chime. Once there, I chose Disk Utility, selected my drive (which is formatted APFS; not case-sensitive or encrypted) and chose First-Aid. It also said my disk seemed okay. As a last resort, after exiting Disk Utility I chose "Startup disk..." from the Apple menu, selected my disk (the only option) and restarted. Voila! Rebooted just fine and has been working great ever since.


It seems that blessing the disk did the trick, but I included all the steps I took, just in case it was something else. Good luck with solving this issue on your MBP.


Just FYI - if you use APFS case-sensitive, OneDrive will not work. Hence why I'm using APFS case-insensitive. Also, there seems to be no way to transition from one to the other without a complete wipe and re-install.


Cheers!

Tony

Dec 9, 2017 6:27 PM

Reply Helpful (1)

Dec 9, 2017 6:36 PM in response to TWhiteX In response to TWhiteX

Gah, sounds like that might have worked here. Sadly too late for me to test, I decided to purchase a replacement SSD and do a clean install. That worked fine, and from there I could do a straightforward transfer of the old disk's data using migration assistant.


A bit of an expensive solution, but worked for me. On the plus side i now have a spare SSD knocking about that i can use as a time machine backup and avoid this problem in future 😉

Dec 9, 2017 6:36 PM

Reply Helpful
User profile for user: margarettajune

Question: Macbook Pro won't boot after installing High Sierra