Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: One Mac showing two IPs

Why is ARD showing two IPs for just one of my Macs?


User uploaded file

Ido not have multiple IPs setup

User uploaded file

Thanks for your help {-)

iMac, macOS High Sierra (10.13.1), 32GB Ram 4GB Graphics 1.1TB SSD 27"

Posted on

Reply
Question marked as Solved
Answer:
Answer:

The long address is an IPv6 one. If you're not aware of the differences the following explains them quite well:


https://www.internetsociety.org/deploy360/ipv6/?gclid=Cj0KCQiAus_QBRDgARIsAIRGNG ilcskCOCNZRVtb5TJsElT4hxOxU-OEWLwzFCDHwIeJf2xOJ3WiXR4aAmYTEALw_wcB


Your mac is primed to receive an IPv6 from whatever routing/network/firewall device you connect to. If you have control over your firewall (BT Home Hub for example) you can disable the option. BT Home Hubs dole out IPv6 addresses by default and maybe your DHCP server does the same?


You can't disable IPv6 using the GUI on a Mac. You have to use a terminal command instead. Depending on your hardware and which network port you want to disable it on, this can be any or all of the following:


networksetup -setv6off Wi-Fi

networksetup -setV6off Ethernet

networksetup -setv6off "Thunderbolt Ethernet"


You will need to precede the above with sudo or, depending on your OS version, you'll be prompted for an admin name and password. You can send the above to target workstations using ARD's Send Terminal Command option. Make sure you send the command as root. Once sent it's a good idea to reboot the macs in question as well as removing the entry for those macs in ARD and re-adding them.


Hopefully this may help?


Tony

Posted on

Page content loaded

Question marked as Solved

Nov 21, 2017 6:14 AM in response to James Rothschild In response to James Rothschild

The long address is an IPv6 one. If you're not aware of the differences the following explains them quite well:


https://www.internetsociety.org/deploy360/ipv6/?gclid=Cj0KCQiAus_QBRDgARIsAIRGNG ilcskCOCNZRVtb5TJsElT4hxOxU-OEWLwzFCDHwIeJf2xOJ3WiXR4aAmYTEALw_wcB


Your mac is primed to receive an IPv6 from whatever routing/network/firewall device you connect to. If you have control over your firewall (BT Home Hub for example) you can disable the option. BT Home Hubs dole out IPv6 addresses by default and maybe your DHCP server does the same?


You can't disable IPv6 using the GUI on a Mac. You have to use a terminal command instead. Depending on your hardware and which network port you want to disable it on, this can be any or all of the following:


networksetup -setv6off Wi-Fi

networksetup -setV6off Ethernet

networksetup -setv6off "Thunderbolt Ethernet"


You will need to precede the above with sudo or, depending on your OS version, you'll be prompted for an admin name and password. You can send the above to target workstations using ARD's Send Terminal Command option. Make sure you send the command as root. Once sent it's a good idea to reboot the macs in question as well as removing the entry for those macs in ARD and re-adding them.


Hopefully this may help?


Tony

Nov 21, 2017 6:14 AM

Reply Helpful (1)
User profile for user: James Rothschild

Question: One Mac showing two IPs