Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: High Sierra DisplayPort issues

So here's the situation:


2016 15" MacBook Pro

macOS 10.13.1

Dell P2715Q External montior


I've been using this monitor setup for about a year and a half. Since upgrading to High Sierra I have been experiencing issues. Using the laptop open and connected to the external display everything is totally fine. However, when I close the lid to use it in closed clamshell mode the computer freezes and I have to force reboot the computer. Sometimes the external screen will show a bright red color. I am using a USB-C to DisplayPort cable to connect directly to the monitor.


If I use the HDMI adapter to connect to the monitor everything works fine. I can use closed clamshell with no issues. My assumption is that this is an OS bug. I have tried resetting SMC, NVRAM, and even reinstalled 10.13.1 via Internet Recovery with no luck. I don't believe this is an issue with the cable or the monitor itself since everything works fine when its not in closed clamshell.


Is anyone else experiencing an issue or have any solutions aside from ones I've tried?

MacBook Pro (Retina, 15-inch, Mid 2015), macOS High Sierra (10.13.1)

Posted on

Reply

Page content loaded

Dec 22, 2017 6:03 PM in response to circa19372 In response to circa19372

Same issue for me. Mac Mini Late 2012, using and lG Ultrawide monitor; DisplayPort to Mini DisplayPort. Had zero issues with monitor or cables prior to High Sierra. A couple days after High sierra and my monitor goes haywire and won’t detect display. Tried two more brand new cables and still no go. It will connect via hdmi but I lose the resolution of the ultrawide. Hdmi is not the solution. What is going on with this it’s driving me nuts!

Dec 22, 2017 6:03 PM

Reply Helpful

Jan 15, 2018 1:47 PM in response to MEDIAWiRX In response to MEDIAWiRX

I am having the exact same issue with my ASUS MX229Q ultra wide screen display. It will connect with the HDMI, but the resolution is stretched, as it always was which is why I use the Thunderbolt to displayport cable. It was working a couple of days ago, but now my display says 'no signal'. My MacBook Air recognizes that the display is there in the display system preferences. Please help!

Jan 15, 2018 1:47 PM

Reply Helpful

Jan 15, 2018 10:39 PM in response to Sean Meredith In response to Sean Meredith

Read back on all the threads here if you haven't. Most issues have been answered that it is a displaylink driver problem.


Go here, http://www.displaylink.com/downloads and download the updated driver for your OS from Dec, and restart your computer. You might find that you need to disconnect the monitor afterwards, then plug back in if it doesnt recognize.


ALSO, the drivers need to be cleared for security in High Sierra now in order for them to be enabled. Read here to make sure you do that after install of the update. http://support.displaylink.com/knowledgebase/articles/1188004-macos-high-sierra- video-functionality-not-enabled


All of this should work for most of the issues listed in this thread. Keep trying, and check for any monitor control software from your manufacturer. LG has some new OnScreen control software that can be downloaded. Perhaps you have something to update there as well? Keep working on it.


I had issues with my LG Ultrawide monitor right after updating my Mac Mini Late 2012 to High Sierra from El Capitain. I connect my ultrawide monitor to the Thunderbolt/displaylink on the mini to the displayport on the monitor, and a Dell monitor to the HDMI port. Once I updated, the displayport was working correctly and all is good.

Jan 15, 2018 10:39 PM

Reply Helpful

Feb 3, 2018 3:06 PM in response to MEDIAWiRX In response to MEDIAWiRX

I have similar issues with High Sierra and my LG 4K monitors connected to my 15-inch MBP 2016 via DisplayPort adapters. The monitors worked fine under Sierra, but are misbehaving badly under High Sierra. I am downloading and installing the updated driver from displaylink.com to see if that fixes the issue.


Anyone know why Apple didn't include the correct driver as part of High Sierra, or at least as part of a recent update? That seems very strange to me, especially since DisplayPort is not some niche technology. You would think someone in Apple's QA group would have noticed the anomalous behavior with a DisplayPort monitor when they're testing High Sierra.

Feb 3, 2018 3:06 PM

Reply Helpful (2)

Feb 27, 2018 4:21 AM in response to circa19372 In response to circa19372

Same issue when upgrading to High Sierra on a 27in Samsung Display, can no longer get HiDPI 2560x1440. Funny thing is I have the same display at work, both show different issues, one does not turn on at all, one flickers, both occasionally turn on after a reboot. Was fine before upgrading... 😟

Feb 27, 2018 4:21 AM

Reply Helpful
User profile for user: circa19372

Question: High Sierra DisplayPort issues