Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: 2017-11-18 Sierra Security Update bricks 2012 MacBook Pro Retina

After choosing to run the new Security Update issued this morning for Sierra on my 15" 2012 MacBook Pro Retina, it never booted normally again. The update process seemed to never complete and I've been able several times to get the startup chord to play and to see the backlights of the keyboard, but the screen has, almost without exception, remained black. No gray apple at boot, nothing.


Attempting to boot into Firewire Target Disk Mode with the Thunderbolt to FW800 adapter and an 800 to 800 cable connected to my Mac Pro fails, again with nothing but a black screen. No external disk becomes visible to the Mac Pro.


Updating the NVRAM and the SMC of the MBP both seem to accomplish nothing. Booting into Safe Mode likewise.


Twice, while holding down the power button (and perhaps inadvertently the key right below it) I momentarily saw the login screen with two login choices side by side but it wouldn't remain visible for over 1 second and I couldn't get anywhere at that point e.g. entering my password to log in.


This is almost certainly a software issue, as it occurred precisely when the Security Update was done, but I've not been able to find a single reference to this happening searching on posts over the last 24 hours using a variety of search terms. With a black screen it's always very difficult to tell what the heck is going on.


Well... After about 45 minutes of not working, then taking the time to write the above, I just re-opened the MBP and voila, there was the logins screen, looking as though everything was fine, and the notice "You shut down your Mac because of a problem" (several times, actually). I had waited plenty long for processes to complete, but something had to have gone very wrong during the Security Update process. The App Store application says that it was successfully installed. Consider this a warning and a bug report both.


Closing (sleep) and re-opening the MBP twice have worked normally so far, so the storm seems to have passed.

MacBook Pro (Retina, Mid 2012), macOS Sierra (10.12.6)

Posted on

Reply

Page content loaded

Nov 18, 2017 1:34 PM in response to Joseph Holmes In response to Joseph Holmes

Two minutes after posting that, I attempted to boot into FW Target Disk Mode, and again the chord played but the screen remained black and the disk never showed up on the Mac Pro to which it was connected. Force shut down again. And again the following normal boot fails to work. The chord plays and the screen remains black for minutes but they keyboard backlights are on. Attempting to enter my password without knowing whether the cursor is in the text entry box is not working, despite experimenting with varying numbers of tabs. Next move is to close the lid and wait for a while, to see if that again allows the screen to not be black. Re-open at about one minute: Success > Login screen. I see that tabbing won't get me into the text entry box. So after getting to the desktop I went to Users and Groups and re-set the laptop back to its usual state of Automatic login as me, rather than it being set to Off, so as to bypass the login screen next time, hoping that this avoids the bug.


Restart test in that state: Failure, the screen remains black. Close the lid for just 10 seconds this time: No luck, still black upon opening (key backlights are on). Close the lid for ~60 seconds again (machine set on its left side, on edge - you never know, an accelerometer might be affecting the results): Failure! Screen is black again, so the earlier trick to recover is not working.


In any case it looks like there is a terrible bug which was introduced with the OS Security Update which doesn't affect sleep-wake changes once operating normally but does affect both cold boots and Restarts, causing a very persistent black screen.


Force shutdown again. Close the lid and wait for about a minute. Open the lid and boot with the power button. Normal chord occurs but screen remains black so far, 40 seconds, 1 minute, 2 minutes, key backlights are on as usual, 3 minutes, screen backlight level has never been set (by me) to off during this entire test, after about 4 minutes I close the lid again and again wait for some time in hopes that the screen will once again return upon waking the machine (assuming that it was operating normally except for the screen being black, then goes to sleep when closed and wakes up when opened). All along I've not heard an fan sounds at all. Success! It's awake again.


At this point I'm not exactly anxious to attempt to zap the NVRAM or reset the SMC again. But I tried resetting the SMC again anyway, but booting afterwards is still bad. Black screen. Again attempting to get to the desktop by closing the laptop for about a minute and re-opening the lid: success. I'm not holding out much hope for yet another round of resetting the NVRAM (in case it didn't work earlier), so before I go any further I'm going to do a fresh cloned backup of the entire ¾ TB SSD.

Nov 18, 2017 1:34 PM

Reply Helpful
User profile for user: Joseph Holmes

Question: 2017-11-18 Sierra Security Update bricks 2012 MacBook Pro Retina