Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMovie clips won't import but they are already in my project

I uploaded a bunch of clips from my camera and they all showed up in the Project Media so I went ahead and created my project and completed it. Now I go to share the movie I made and It won't let me because some of the clips never imported and are being read directly off my camera as if it's an external drive. The clips in question have a tiny camera on them signifying this. I have just spent hours creating this video. How do I get these clips to import into iMovie so I can share the movie?


I am using iMovie 10.1.6

MacBook Pro

Posted on

Reply

Page content loaded

Nov 18, 2017 1:52 PM in response to sunnyisagirl In response to sunnyisagirl

I tried to re-imort one of the clips and it did not import. I have disconnected and re-connected my camera. I have rebooted.

Nov 18, 2017 1:52 PM

Reply Helpful

Nov 18, 2017 7:32 PM in response to sunnyisagirl In response to sunnyisagirl

This issue comes up now and then and there has never been a solid solution, Sometimes it is because the import was cut short and the abswer was to give it lots of time during the import. Another solution has been to reimport as you have tried. What you can try is to use image capture to import the failed clips into your computer and then try to import into iMovie. If that fails you can convert to MP4 using the free HandBrake app and try that. Will the clips open in Quicktime?

Nov 18, 2017 7:32 PM

Reply Helpful
User profile for user: sunnyisagirl

Question: iMovie clips won't import but they are already in my project