7 Replies Latest reply: Jan 17, 2007 12:06 PM by KiwiBuzz
KiwiBuzz Level 1 Level 1
Often, not long after I start up, I experience a delay between typing or deleting - or anything else from the keyboard - and the response from the screen. Sometimes severppears to be restricted to Mail.

Any ideas?

MacBook Pro, Mac OS X (10.4.8)
  • David Gimeno Gost Level 7 Level 7
    Sometimes actions that require disk access may experience a delay because the disk was put to sleep and it takes a few seconds to wake it up. The next time the same data must be loaded from disk the delay may not occur if the data has been cached in memory and physical access to the disk isn’t necessary.

    That may or may not explain what you’re observing, but would explain why it happens some time after start up but neither immediately (because the disk has not been put to sleep yet) nor repeatedly (because the data on disk may have been cached in memory).
  • KiwiBuzz Level 1 Level 1
    Thanks for that, but my problem seems to be different because the delay continues as I type. I can easly get one word ahead of the screen. Deleting is dodgy because I have to wait after each press.
  • David Gimeno Gost Level 7 Level 7
    This could be a spell checking issue. Do you have a third-party spell checker installed? What are your Mail > Preferences > Composing > Check spelling settings? Try changing them to Never and see whether that makes a difference.
  • KiwiBuzz Level 1 Level 1
    I did that and restarted Mail.
    It is now OK. But that doesn't yet prove anything as restarting often was a temporary cure.

    I'm using Apple's spell checker. I note that I get the delay even when clicking on 'Subject' after typing the address. Difficult to see how a spell chancker could get in the way of that. But we shall see.

    Thanks anyway.
  • David Gimeno Gost Level 7 Level 7
    You’re welcome.

    I get the delay even when clicking on 'Subject' after typing the address.
    Difficult to see how a spell chancker could get in the way of that.


    Not sure what you mean. If I check spelling as I type, Mail does certainly underline in red any misspelled words in the Subject...
  • Clique of One Level 2 Level 2
    expertise.macosx
    Mac OS X
    Any chance the 'Slow Keys' button is selected (On) in Keyboard>Universal Access>System Preferences.

    eMac 800 MHz, iMac Bondi Blue, iMac DV SE 400 MHz Graphite   Mac OS X (10.4.8)   iBook (Firewire) 466 MHz Graphite, iBook G4 1.33 MHz 14"
  • KiwiBuzz Level 1 Level 1
    I seem to have solved it. Via 'Menu Meters" I noted that the processor was very busy while I was typing. So I opened Activity Monitor and found that "Caps warn" and 'typeit4me' were very busy - as was Mail. So I downloded that latest version of both and all seems to be well.

    Thanks to those who responded.