1 Reply Latest reply: Jan 16, 2007 10:07 PM by Foreign Devil
Martin R. Lerch Level 1 Level 1 (35 points)
For quite some time now I experienced problems with my WDS Airport network at my home office (Airport Extreme base and Airport Express remote - NAT provided by OS X Server 10.3). My MacBook Pro would have problems staying connected to my Airport network. Kept on disconnecting, or showed that it was connected, but couldn't see any of the Airport base stations. Very strange.

I also noticed that it must have had something to do with my neighbors' wireless networks around me. It seemed that whenever a neighbor's wireless network came online it bumped me off.

Anyway, after experimenting with WEP, WAP and WAP2 encryptions, as well as with Open network settings only with access control list I gave up. My MacBook Pro Core 2 Duo simply couldn't stay connected.

So I started digging around a bit and I found posts that described similar issues for others with other computer models like Power Book G4, iMac, etc. Now, my Power Book G4 never had any issues staying connected to my Airport network (used to anyway).

I read in one of the posts that it may have something to do with the Airport Extreme (V5.7) and Express (V6.3) Firmware updates. So I decided to take the plunge backwards and downgrade my Airport Extreme/Express Firmwares to V6.1.1 for Express and V5.5.1 for Extreme.

The downgrade went ok. Initially I had no connection (I guess because my last setting used WAP2 which is not available for the older Firmwares, so the config file was not the right format), but after resetting my Airport Base Stations to WAP I had connection.

At night I put all of the computers on the Airport Network to sleep. In the morning I woke my Mac Book Pro from sleep only to discover that no Airport Network was available.

So I logged in to the Airports from the server and pretty much tried everything. Set it to WEP 40, WEP 128, back to WAP encryption.. nothing worked (non of the computers on the Airport Network were able to connect anymore). So I finally gave up and had to settle for an open network without encryption, only access control list and closed network, and guess what. It worked. All computers can once again connect to the Airport network, and no matter what goes on with my neighbors and their networks I can stay connected. Putting the Mac Book Pro to sleep, waking up.. connected. No more disconnects now for the last 24 hours. I know it's too soon to tell.

But it seems that there may be some sort of problem with the latest Airport Firmware upgrades. Downgrading must have destroyed something though, because now none of the encryptions are working anymore.

If anyone has any idea on what I could do to solve this issue, that would be appreciated. Should I try to hard reset both base stations? Maybe that would do the trick?

Also, could it be that I may have copied old files with the migration assistant that belong to the PowerPC Airport drivers? Maybe that is messing things up. Anyway, have no clue.

All in all, I am happy with my Airport network, but not being able to have encryption worries me a bit. Also the speed leaves room for improvement. I have never seen my Airport network go faster than 12 Mb/s (of a theoretical 54Mb/s ... wow).

Anyway.. just thought I would throw this out there and see if someone has anything to contribute.

Mac Book Pro C2D 17"   Mac OS X (10.4.8)   iPhone needs a cam in the front
  • 1. Re: Firmware downgrade helped - for what it's worth
    Foreign Devil Level 1 Level 1 (0 points)
    I feel your pain. Started logging on this morning with our computers (once we got power back on from a broken pipe) and man is it a mess. My wifes MacBook Pro wont remember our ABES network, nor will it show up. If we select other from the drop down airport icon and manually type in the name and password it is fine until we shut it down or restart it.

    Unfortunately, my daughters newer iBook G4 cant even find our network, however, it will find other networks floating around the neigborhood. Go figure!

    My sons snow G3 iMac this morning is having the same problem as my daughters laptop.

    Our G4 iMac has no problem at all getting on the network and/or remembering it and automatically connecting to it when restarted/shutdown.

    My Toshiba M35 laptop cant find the network but will find others and connect to them.

    My 2 Dell Inspiron 5100 (one with an internal and another with a Belkin PCMCIA wireless) both connected to the base stattion with no problems.

    Now, isnt that weird or what? We have soft reset the AEBS several times as well as hard reset with the same results as above. Anybody have any ideas?

    Thanks,
    Sean

    P.S. This is after we have been running the current network/setup for about a year with no hiccups. Got to love apple and its firmware upgrades!