Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Email sound missing after recent updates.

Got a new iPhone 7 Plus and a two year old iPhone 6. Both been restored from iCloud backup with new SIMS. Sound/vibrate lever up, notifications set to badge and sounds. The problem started with iOS 11 updates. Grateful for any suggestions.

iPhone 7 Plus, iOS 11.2, 128GB

Posted on

Reply
Question marked as Solved
Answer:
Answer:

So you are saying that a sound for email is the only one missing? Are you referring to a sound for receiving an email, or something else? Please describe clearly.

Posted on

Question marked as Helpful

Dec 9, 2017 8:43 AM in response to Wildie In response to Wildie

You say that you have checked notifications and made sure that a sound is selected, and that the mute switch is on sound, so now check to ensure that the device is not in Do Not Disturb, and that you have the volume turned up to a level to hear.


You can also try changing the sound for receiving an email and see if that shocks it into working again. You can also try just powering the phone off and back on again. Worse case, create a backup and restore to that backup.

There’s more to the conversation

Read all replies
Question marked as Helpful

Dec 9, 2017 8:43 AM in response to Wildie In response to Wildie

You say that you have checked notifications and made sure that a sound is selected, and that the mute switch is on sound, so now check to ensure that the device is not in Do Not Disturb, and that you have the volume turned up to a level to hear.


You can also try changing the sound for receiving an email and see if that shocks it into working again. You can also try just powering the phone off and back on again. Worse case, create a backup and restore to that backup.

Dec 9, 2017 8:43 AM

Reply Helpful (1)

Dec 9, 2017 8:55 AM in response to ChrisJ4203 In response to ChrisJ4203

I tried all the resets and restores a few days ago. I have now tried sending from my partner's phone to both of my email addresses and one has sounded but not the other, though I can't see any difference between the settings for each. I think I will book into the Genius Bar when I have time and see what they say. I'm not hopeful that the local apple store will have a solution that can't be found on here, feels like dodgy OS build to me. I'm used to weirdness on Android which is why I only use it to save battery on important devices, but in five years on iPhones I have never had a single problem till now.

Dec 9, 2017 8:55 AM

Reply Helpful

Dec 10, 2017 7:05 AM in response to Wildie In response to Wildie

It is not impossible for you to have two different settings for two different email accounts. You can also have two different sounds set, one for each account. If you open Settings>Mail>Notifications, you should see the switch for Notifications, and also each of your mail accounts listed there Click on each one, and ensure that a sound is set for each one, and that you have all of the alert settings fixed. It might not hurt to try changing the sound for the one that is not working correctly. See if that helps. I don't think this is an iOS issue, as I've not seen many reports about just a single mail account not creating a notification sound when the other works. You don't happen to have an Apple Watch do you?

Dec 10, 2017 7:05 AM

Reply Helpful

Dec 10, 2017 10:51 AM in response to ChrisJ4203 In response to ChrisJ4203

Thank you for your further consideration of my problem. Having spent a morning in the company of an Apple tech advisor on the phone, resetting and reinstalling the iPhone 7, all to no avail, it struck me that it was likely something peculiar to the clara.net server, particularly as it kept downloading the undeleted emails on the server. I logged into Claranet's web portal and deleted every email in sight, over 3500 of them. That seems to have fixed the problem - I am now getting sounds on all three of my email accounts although the Clara and Gmail servers don't seem to push, whereas my iCloud account does. I'll give it a few more days then back up the 7 Plus to iCloud, then reset and restore the 6. Both should be OK then. Again many thanks for your time and help.

Dec 10, 2017 10:51 AM

Reply Helpful

Dec 10, 2017 3:14 PM in response to Wildie In response to Wildie

You're welcome. If you don't have a paid Gmail account, it will not push using the standard Apple mail app. However, it will push if you use the Gmail app. I'm not sure about the other account. That would only push if it is an Exchange account. IMAP or POP accounts do not support push. Glad you are on the road to getting it narrowed down.

Dec 10, 2017 3:14 PM

Reply Helpful
User profile for user: Wildie

Question: Email sound missing after recent updates.