Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Home Kit / App Invitation Issue

My husband sends me an invite to join his Home kit on the Home App, but no invitation appears on my Home app. We've tried pretty much everything and can't figure it out.


His phone: iphone 7, My phone: iphone 6s plus

Phones are both updated

Uninstalled and reinstalled Home app

Toggled Keychain on both phones,

Cancelled and resent invitations over a dozen times

I switched my apple ID from "@me" to "@icloud"

Turned off Home on icloud settings, and tried the app to turn it on there... still nothing

Turned off Two step authentification, and nothing... so turned it back on

Tried adding him myself, and it says that his email is not registered with icloud even though it is

He's using a hotmail account, but that shouldn't be a factor if its registered with icloud.

Also "Home" app doesn't appear in both our Settings. It only appears in icloud settings, is that normal?


What other options are there? Would appreciate all the help!

iPhone 6s Plus, iOS 11.2

Posted on

Reply

Dec 11, 2017 8:09 AM in response to zeus520 In response to zeus520

Hello zeus520,

Thanks for reaching out to the Apple Support Communities. I understand you're having some trouble adding someone to Homekit, and I have some information that may help.

Have a look at the article below for some helpful troubleshooting steps and set up help.

Use the Home app on your iPhone, iPad, and iPod touch - Apple Support


If you run into any trouble, or if the symptoms persist, please reach out again.
​Best Regards.

Dec 11, 2017 8:09 AM

Reply Helpful

Dec 11, 2017 8:23 AM in response to sarah_s1 In response to sarah_s1

I’m having the same issue with four devices. I started a new home and I cannot invite my family. I was able to last week and these same devices are on another home. I get a error message when I tap their iCloud email address stating that the address is not a registered iCloud address.

I scrolled through my contacts and two came up in yellow writing allowing me to invite those but they are not the people I want to invite. I guess yellow means iCloud active and black means not. I’ve followed all the steps the original poster has done as well. I think this is a iOS 11 issue.

Dec 11, 2017 8:23 AM

Reply Helpful

Dec 14, 2017 1:16 PM in response to sarah_s1 In response to sarah_s1

Same problem here! My husband was on our Home Kit but it got disconnected. So I deleted him and tried to re-invite him but now it says that his email is not register with iCloud (which is not true. He is on my family share plan). The updates this morning to iOS 11.2.1 did not help this. We updated both iPhones and both iPads as well as the Apple TV.

Dec 14, 2017 1:16 PM

Reply Helpful

Dec 30, 2017 11:38 PM in response to zeus520 In response to zeus520

Another datapoint to affirm this same problem: I just bought an AppleTV 4K specifically for HomeKit automation and when I try to add my wife to the Home app, I get the same message that her AppleID is not registered with iCloud. She certainly is and we have family sharing enabled for location tracking. I tried her @mac.com, @me.com and @icloud.com mail addresses separately (as well as selecting her from the automatic family member suggestion) and it's always the same problem. Definitely a bug.

Dec 30, 2017 11:38 PM

Reply Helpful

Jan 31, 2018 9:32 AM in response to td0239 In response to td0239

Could you try and invite somebody else? Just to see if the problem with the so-called not being registered in iCloud mail addresses is solved for you or that it was just the update & restart which forced the invite to go through in some way.

I deleted/cancelled the pending invite before updating to 11.2.5 so I'm not sure if the same thing would have happened.

Jan 31, 2018 9:32 AM

Reply Helpful
User profile for user: zeus520

Question: Home Kit / App Invitation Issue