Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: sound from USB Parasound A-D unit drops

I have a new Parasound zphono usb preamp and digital interface which I'm using to rip my vinyl collection. When I first got the device my iMac (late 2012) was on Sierra and the device worked perfectly. When High Sierra was installed the problems started. The audio from the device would drop. First I checked with Audio Hijack support but they pointed to no input from the device. Next I tried a different USB cable for the unit but that made no difference. I contacted Parasound and they very nicely exchanged the device for another new one. I installed High Sierra 10.13.2 which has a fix for third-party USB audio devices. I could record 1 LP but then the problem of no audio coming into the system started again.


I don't believe there is a problem with the Parasound device. Their support has no reports of hardware problems. Seems the audio problems started with High Sierra and the latest fix does not work for my situation.


Would anyone have any insights into this problem?

iMac (27-inch, Late 2012), macOS High Sierra (10.13.2)

Posted on

Reply

Dec 10, 2017 5:44 PM in response to mazapan In response to mazapan

Have you tried re-setting the System Management Controller (SMC)?


See the Apple support documentation for this at: support.apple.com/en-us/HT201295


Basic steps are:

  1. Shut the iMac down
  2. Un-plug the power cord for at least 30 seconds
  3. Restore power to your iMac (plug back in)
  4. Start-up normally


This actually fixed a similar problem I had recently getting a new USB Audio adapter (mic + earphone) to work.


Hope it works for you!

Dec 10, 2017 5:44 PM

Reply Helpful

Dec 10, 2017 9:08 PM in response to mazapan In response to mazapan

Hi Mazapan,


I am curious if this is an issue with USB Audio devices in general. For some reason my iMic stops working when I have headphones in. I wanted to have headphones and USB Audio. Nope. The iMac said no. If I pop out the headphones the iMic shows up.


j

Dec 10, 2017 9:08 PM

Reply Helpful
User profile for user: mazapan

Question: sound from USB Parasound A-D unit drops