Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can not access internet via WiFi or ethernet after 10.13.2 update

Mac Mini 2011 8 GB RAM


upgraded from 10.13.1 to 10.13.2


now have absolutely no internet with both WiFi and Ethernet connections, IP address via DHCP is assigned under both


internet on 9+ other devices connecting to the same router are unaffected and normal


tried the fix located below, but it had no effect.


https://becomethesolution.com/blogs/mac/fix-mac-os-x-high-sierra-upgrade-no-wifi -internet-after


Also looked at kext files (see comments), and deleted all that hadn’t been modified in the past year.


Any suggestions? This is 100% software.


Apple needs better QA in software on macOS and iOS. Lots of terrible bugs of late

Mac mini, macOS Sierra (10.12.6)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I got it corrected now. I deleted and redownloaded the 10.13.2 installer and then re-installed over my existing installation. After I did that, my internet connectivity returned to normal.

Posted on

Dec 9, 2017 6:02 PM in response to utrph77004 In response to utrph77004

Wish I could give you the answer, but just writing to let you know similar thing happened to me. I have Mac mini 2012, 4 GB. Same as you, I updated from to 10.13.2 and it's a disaster compared to other downloads I've made. My e-mail won't operate at all and I tried to sign into iCloud and my password was refused....when I was pretty sure I hadn't made a mistake. After trying it several times I got shut out; thanks so much Apple????? I am getting pretty ticked off. I've had a Mac since the beginning...back when Steve started out and he was always ethical and helpful. Now I'm starting to feel like this is evolving into Bill Gates' rubbish. That said, what should we do? I suppose I'm "lucky" I can get on the I/T, BUT I have stuff ordered, etc., and no access to e-mail. Not funny. I don't want to layer more problems into my computer. Should I change my password and if so, how do I do that? I have 3 answers recorded to answer security and it bombed out completely because it asked my date of birth (that's illegal, you know!) - anyway, it didn't work either, but I never remember putting in a dob. Other interesting fact, I transmit my Yahoo mail into my mac mail and now Yahoo doesn't give me direct access to my Yahoo mail. Yahoo is true rubbish, but I still want the ability to use the old email I have there. And why the heck would Yahoo not operate either - no graphics on the page for instance. I semi-apologize for being angry because people here are very helpful and I'm hoping someone can come to the rescue, please?

Dec 9, 2017 6:02 PM

Reply Helpful

Dec 21, 2017 7:47 PM in response to utrph77004 In response to utrph77004

Just adding my voice to the mix. I upgraded 3 client computers to high sierra today: The iMac had already downloaded 10.13.1 a while back and was simply waiting to be allowed to install. Everything went well when I ran it.


The two portables however downloaded 10.13.2. After the install, neither of them can see the internet via WiFi. This is a 2014 Macbook Air and a 2015 Macbook Pro. Both give green lights for WiFi in network preferences and get IP addresses assigned via DHCP (and show a high TX rate)... but browsers won't load pages and the system can't connect to Apple's server.


Very frustrating!

Dec 21, 2017 7:47 PM

Reply Helpful
User profile for user: utrph77004

Question: Can not access internet via WiFi or ethernet after 10.13.2 update