Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: HomeKit invitation failure, "Apple ID not registered with iCloud"

Hi,


This error is driving me insane. Had previously successfully invited my wife to share control of our HomeKit accessories via Home app. Today I installed additional accessories but they weren't all showing up in the Home on her phone. Decided to remove her from the list of people who can control the home (it was only me and her), then tried to re-invite her.


For some reason, the invite sheet inside the Home app doesn't recognize her Apple ID email address as being valid, even though it is!


I tried deleting my "Home" and re-adding all the accessories back and then inviting her, to no avail.


I tried restricting the only email address under her contact card to the iCloud one, didn't work.


I even changed my Apple ID to use my iCloud email address instead of Gmail, but didn't work.


I am at my wit's end. Please help.

User uploaded file

Posted on

Reply

Dec 10, 2017 4:20 AM in response to sherifhanna In response to sherifhanna

I have the exact same issue, with no search results yielding any help. Seems this is an issue that is a couple years old now. Has anyone figured out how to fix this?? The search results about deleting users don’t work for me. Apple, this is a maddening issue here.

Dec 10, 2017 4:20 AM

Reply Helpful (2)

Dec 12, 2017 8:44 PM in response to sherifhanna In response to sherifhanna

Spoke to senior Apple technical support tonight. It turns out that Apple has disabled the HomeKit invitation system for all users, pending some additional security enhancements that will roll out in a new version of iOS (maybe 11.2.1?)


This is likely related to this HomeKit vulnerability that was discovered recently:

https://9to5mac.com/2017/12/07/homekit-vulnerability/

Dec 12, 2017 8:44 PM

Reply Helpful

Dec 12, 2017 9:00 PM in response to sherifhanna In response to sherifhanna

Here's the statement Apple provided to 9toMac, basically confirming that the issue we're having is related to the discovered vulnerability:


“The issue affecting HomeKit users running iOS 11.2 has been fixed. The fix temporarily disables remote access to shared users, which will be restored in a software update early next week.”

Dec 12, 2017 9:00 PM

Reply Helpful

Dec 21, 2017 3:32 AM in response to alucarddelta In response to alucarddelta

Great news: I just downloaded iOS 11.2.5 Beta 2 and the bug has FINALLY been fixed. No work-around (like inviting via a user’s iCloud email, which didn’t work for me) - it just works like it’s supposed to. I’m guessing the new iOS will be pushed out to everyone in the next few days.

Dec 21, 2017 3:32 AM

Reply Helpful

Jan 24, 2018 7:52 PM in response to jeffik In response to jeffik

I figured out the problem. If you are on the latest build (At least 11.2.1), the person you're trying to invite must have iCloud Keychain turned on. Settings->Your Name (above Airplane Mode)->iCloud->Keychain


Turn that on. Saw someone post a recommendation for alternative software that can issue invites, and in the app description it mentioned something about the iCloud keychain. I checked my GF's phone and yep, it was off. Turned it on, and the invite went through finally.

Jan 24, 2018 7:52 PM

Reply Helpful
User profile for user: sherifhanna

Question: HomeKit invitation failure, "Apple ID not registered with iCloud"