Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Purchase failed...

> I am using an application from the Japanese iTunes Store (so I have a Japanese iTunes account).

> I purchased a gift card, and I redeemed it.

> It worked. I could see the balance.

> I tried to purchase in-game purchase. It didn't work. It also showed error code [2037]

> I tried to get to the Appstore to purchase something small just to see if it worked.

> Result: No. I can get everything that is free, but not anything with a price.

> I thought it was a region lag, because I use 2 accounts, 1 Japan and 1 US, and I switch between them a lot.

> I tapped on "Region" to change it to US and then change back to Japan.

> But it didn't let me. It told me I have balance, and have to spend them all before changing region. That means I do have the money in my account to spend.

> On this account, I don't have any credit cards as Payment. I have been using the option "None" since the beginning, and I have been buying gift cards online and redeem them.


> Please help me, what should I do?

iPhone 8 Plus, iOS 11.2

Posted on

Reply
There are no replies.
User profile for user: Sword-shapedStars

Question: Purchase failed...