Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Macbook Pro Long Boot Process

I have a Macbook Pro Early 2011 with a Patriot Ignite 950GB (non-Apple) SSD. After installing High Sierra, the boot process has gone from seconds to minutes. Several minutes, 10 or more. I let the drive get converted to APFS on the upgrade from Sierra. I booted in verbose mode (with Command-V) and there is one step (error) that gets repeated several time, maybe 12 or more that seems to be where I'm seeing the huge delay. the message says:


apfs_vfsop_sync:2928: failed to finish all transactions in sync()! (err 16)


Any thoughts? I'm not able to find any reference to this message anywhere else. I have booted in safe mode and there is not difference in the boot time, if anything it was even longer. I have booted to recovery mode and run Disk Utility First Aid and no errors were found. I have booted to recovery mode and run Reinstall macOS, no change. Next thought is to wipe the drive and start over with a clean install and Time Machine restore but I thought I'd post here before undertaking that pain.


TIA!

MacBook Pro, macOS High Sierra (10.13.2), 17-inch, Early 2011, 16 GB memory

Posted on

Reply

Dec 11, 2017 9:40 AM in response to MarkBoyer In response to MarkBoyer

The only logical explanation is that your SSD is not supported. Installing High Sierra includes a firmware update. Apple only develops firmware for products that Apple builds. Replacing a Mac's internal storage device is not a supported user modification, probably for that reason if not others.


Your options are to research its manufacturer for a firmware update specifically designed for High Sierra, replace it with one manufactured by a vendor known to support Macs, or with a conventional hard disk drive. The only aftermarket SSDs I have used and can recommend with High Sierra are OWC's line of Mercury Extreme Pro 6G models.

Dec 11, 2017 9:40 AM

Reply Helpful
Question marked as Solved

Dec 12, 2017 8:14 PM in response to John Galt In response to John Galt

Thank you for your response. It seems the High Sierra install process turns on trim for an SSD boot drive without regard for it being supported. I turned off trim by opening terminal and entering:


sudo trimforce disable


My shutdown and startup times returned to normal and rebooting in verbose got ride of the original repeated error messages.

Dec 12, 2017 8:14 PM

Reply Helpful (1)

Dec 16, 2017 2:18 PM in response to John Galt In response to John Galt

I am getting the same error message on my Early 2013 Retina MacBook Pro, which comes with a SSD. I started noticing significantly slower booting speed after updating to OS 10.13 and converting to APFS in the process. Is there anyone else with a factory installed SSD and the same error message at startup?

Here's my disk configuration:

/dev/disk0 (internal, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.3 GB disk0 1: EFI EFI 209.7 MB disk0s1 2: Apple_APFS Container disk1 500.1 GB disk0s2 /dev/disk1 (synthesized): #: TYPE NAME SIZE IDENTIFIER 0: APFS Container Scheme - +500.1 GB disk1 Physical Store disk0s2 1: APFS Volume Macintosh HD 236.6 GB disk1s1 2: APFS Volume Preboot 21.5 MB disk1s2 3: APFS Volume Recovery 506.6 MB disk1s3 4: APFS Volume VM 1.1 GB disk1s4

Dec 16, 2017 2:18 PM

Reply Helpful

Dec 29, 2017 2:48 PM in response to EverythingTec In response to EverythingTec

I'm seeing significantly longer start-up times, too. Here's a picture of what happens when I do a verbose startup - nothing happens for 26 seconds before the line "pci pause" appears, and the next two lines also each take more than 1 second.


User uploaded file


I'm on a MacBook Pro (Retina, 15-inch, Early 2013) with an original 500GB SSD.


Suggestions greatly welcome!

Sebastian

Dec 29, 2017 2:48 PM

Reply Helpful

Jan 6, 2018 10:19 AM in response to sebhoff In response to sebhoff

I have the exact same problem with the same error message with the exact same configuration Early 2013 MacBook Pro with Retina Display. I suspect this is related to the firmware of the Apple SSD. Can anyone suggest what to be done? Any help is greatly appreciated.

Jan 6, 2018 10:19 AM

Reply Helpful
User profile for user: MarkBoyer

Question: Macbook Pro Long Boot Process