Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Trying to upgrade graphics card on mid 2010 Mac Pro

I'm trying to upgrade the graphics card on my mid 2010 Mac Pro from an GeForce 750 ti to a 1050 ti on High Sierra 10.13.2. Other relevant stats: 2.8 GHz Quad-Core Intel Xeon, 32 GB 1066 MHz DDR3, 480 GB SSD.


I have installed the card physically and it gets power when it first boots, but does nothing after that. I have the latest drivers installed, but the system won't recognize the card even though it recognizes that there is a card in the slot. The NVIDIA Web Driver installed is 378.10.10.10.25.102. The CUDA is 387.99. I know the card works because I tested it on my boot camp. I've also tried removing the ATI Radeon HD 5770 1 GB that came with the computer. Currently, the ATI Radeon is the only driver that allows me to produce images. Under the Mac Pro Hardware, PCI reading it says this:


Name: NVDA,Display-F


Type: Display Controller


Driver Installed: Yes


MSI: No


Bus: PCI


Slot: Slot-2


Vendor ID: 0x10de


Device ID: 0x1c82


Subsystem Vendor ID: 0x1458


Subsystem ID: 0x0010


ROM Revision: preset 1.0.0


Revision ID: 0x00a1


Link Width: x16


Link Speed: 2.5 GT/s


It also says there is an audio device in the same PCI port


Type: Audio Device


Driver Installed: No


MSI: No


Bus: PCI


Slot: Slot-2


Vendor ID: 0x10de


Device ID: 0x0fb9


Subsystem Vendor ID: 0x1458


Subsystem ID: 0x3763


Revision ID: 0x00a1


Link Width: x16


Link Speed: 2.5 GT/s


Please help me get it to work!

Mac Pro, macOS High Sierra (10.13.2), GeForce 1050 ti

Posted on

Reply
There are no replies.
User profile for user: bbonellatgs

Question: Trying to upgrade graphics card on mid 2010 Mac Pro