Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: FCPX - Import Media Files CRASHING

After upgrading to High Sierra (even after 10.3.2), FCPX 10.3.4 simply cannot import media files (crashed immediately). Mine is iMac 21” with Fusion drive. However it works on my much slower MacBook Air old model. I am now totally stuck and cannot start my new FCPX project on my iMAC… SIGH SIGH SIGH...

iMac (21.5-inch, Late 2012), macOS High Sierra (10.13.2), With Fusion Drive 1TB

Posted on

Reply

Dec 12, 2017 12:24 PM in response to AhWongCK In response to AhWongCK

Hello, AhWongCK.

It’s my understanding that you’re unable to use Final Cut Pro X on your iMac using macOS High Sierra and that it keeps crashing. I would recommend checking out this article which has multiple steps to help resolve issues with Final Cut Pro X: Resolve an issue in Final Cut Pro X
Let me know if this helps.
Thank you for using Apple Support Communities.
Cheers!

Dec 12, 2017 12:24 PM

Reply Helpful

Dec 12, 2017 11:53 PM in response to Allen A In response to Allen A

Thanks Allen. Before I reported the problem, I had already gone thru the article you mentioned. I had tried all the suggested options, except the 'reinstallation of the FCPX' ( afraid that would lose all my plugins ). Anyway, if it seems not a 'common' problem to others ( iMac Fusion drive users ), then may be I will give this 'reinstallation' a try.


Will let you know how it goes...


Good luck on me...
WongCK

Dec 12, 2017 11:53 PM

Reply Helpful

Dec 13, 2017 12:13 AM in response to AhWongCK In response to AhWongCK

Hi Allen,


Just finished reinstalling the FCPX (10.3.4), no luck... the problem still persists...


The trouble report, as usual, was sent to Apple for follow up...


SIGH SIGH SIGH... HELP HELP HELP... was stuck on this for almost 2 weeks now... :-(


... very very much regretted to have upgraded to the High Sierra. ( Too bad that I had not ensured that I resumed my Time Machine properly set up before I did the High Sierra upgrade... a very bad lesson learned. ... I somehow used my Time Machine hard disk to store data for my recent USA trip. :-(

Dec 13, 2017 12:13 AM

Reply Helpful

Dec 13, 2017 12:16 AM in response to AhWongCK In response to AhWongCK

By the way, as I mentioned before, I strongly believe that it must be linked to the Fusion drive subject (not supported by High Sierra) of my iMac. The problem does not exist for my MacBook Air that does not have fusion drive. ????

Dec 13, 2017 12:16 AM

Reply Helpful

Dec 13, 2017 4:04 PM in response to AhWongCK In response to AhWongCK

I further searched for a solution and found the following similar problem reported by someone else:FCPX crash on file import


It mentioned about 'forcing' the FCPX Import screen to pop up by inserting an SD card (with video files). I tried and it worked... but then failed again if I took the normal click for the "Import" function.


It also mentioned about testing with login via another account. I tried it with the Guest account. The problem did not happen. I then went back to my normal account. It failed on first attempt... but then 'miracle' came when I restarted the computer and tried again... it works. Wow...


Seems the FCPX Import Crashing problem is getting away from me (which is very good)... but then another problem comes up... FCPX (actually my iMac) failed to recognise my 2 external hard disks ( a 2big 6TB Lacie and a Seagate 4TB). Sometimes it can recognise both and sometimes either one and sometimes none... different outcome from different boot up. And I have to manually 'mount' using the Disk Utility. This is very annoying. I tried various fixes but in vain ( eg disconnect hard disk, turn on iMac again, connect hard disk, then turn on hard disk... it mounted... restart iMac... connection dropped again... restart, failed to connect ... restart, connection ok ... restart, failed to connect ... etc etc). And from the web, I saw many others also complaining about the external hard disk connection issue... very annoying. ( By the way, may be I need to post this again with another topic title or join the other topic forums. )glen


Anyway, thanks Allen for the kind advice... but then seems the High Sierra still have quite some instability requiring fixes...

Dec 13, 2017 4:04 PM

Reply Helpful (1)
User profile for user: AhWongCK

Question: FCPX - Import Media Files CRASHING