Related Article

Fix unexpected quits or launch issues in iTunes for Windows

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iTunes refuses to launch. Please help!

I have long had iTunes on my Windows 10 Lenovo. Several weeks ago, it quit launching. I uninstalled and re-installed iTunes, but the problem persists: iTunes refuses to launch. Please help!

Posted on

Reply
Question marked as Solved
Answer:
Answer:

If iTunes is apparently installed correctly try the following in turn until iTunes opens/closes/reopens normally:


  • Remove any SD card that might be in a card reader.
  • Exit the BTTray.exe Bluetooth utility if installed.
  • Locate the shortcut for iTunes, right-click on it, and select Run as administrator. Doing this once may fix certain launch issues. Some users were finding that with the 12.6.1.25 build they had to use this method every time and modified the shortcut accordingly.
  • Try holding ctrl+shift as you launch iTunes so it opens in safe-mode. Again doing this once may sometimes help.
  • Try disconnecting your computer from the Internet before running iTunes.
  • Delete the iTunes shortcuts from the start menu, desktop, task bar, or similar, then repair iTunes from the programs and features control panel.
  • Try Fix unexpected quits or launch issues in iTunes for Windows - Apple Support and test the behaviour in a different user profile or with a different library. If the problem only exists in your profile it may be possible delete some of the iTunes preference files which it would seem that iTunes may be choking on. We can go into details later if the issue is limited to your own profile.
  • Temporarily disable any non-Microsoft anti-virus and see if that has any impact on the behaviour.
  • See the second box in Troubleshooting issues with iTunes for Windows updates for detailed tear down and rebuild advice. Disable any non-Microsoft anti-virus software when reinstalling and run the installer as the administrator.
  • Or see the iTunes installers section of the troubleshooting tip and reinstall the last version that worked correctly for you.


tt2

Posted on

Question marked as Solved

Dec 13, 2017 3:35 PM in response to sspragens In response to sspragens

If iTunes is apparently installed correctly try the following in turn until iTunes opens/closes/reopens normally:


  • Remove any SD card that might be in a card reader.
  • Exit the BTTray.exe Bluetooth utility if installed.
  • Locate the shortcut for iTunes, right-click on it, and select Run as administrator. Doing this once may fix certain launch issues. Some users were finding that with the 12.6.1.25 build they had to use this method every time and modified the shortcut accordingly.
  • Try holding ctrl+shift as you launch iTunes so it opens in safe-mode. Again doing this once may sometimes help.
  • Try disconnecting your computer from the Internet before running iTunes.
  • Delete the iTunes shortcuts from the start menu, desktop, task bar, or similar, then repair iTunes from the programs and features control panel.
  • Try Fix unexpected quits or launch issues in iTunes for Windows - Apple Support and test the behaviour in a different user profile or with a different library. If the problem only exists in your profile it may be possible delete some of the iTunes preference files which it would seem that iTunes may be choking on. We can go into details later if the issue is limited to your own profile.
  • Temporarily disable any non-Microsoft anti-virus and see if that has any impact on the behaviour.
  • See the second box in Troubleshooting issues with iTunes for Windows updates for detailed tear down and rebuild advice. Disable any non-Microsoft anti-virus software when reinstalling and run the installer as the administrator.
  • Or see the iTunes installers section of the troubleshooting tip and reinstall the last version that worked correctly for you.


tt2

Dec 13, 2017 3:35 PM

Reply Helpful (2)
User profile for user: sspragens

Question: iTunes refuses to launch. Please help!