Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Final Cut Pro won't work with High Sierra

I upgraded to High Sierra today and of course in typical Apple fashion was not notified that Final Cut Pro would no longer work. As I tried to open Final Cut Pro, I got a message "the version of Final Cut Pro installed on this Mac is not compatible with macOS High Sierra. Download the latest version from the app store." But, when I click on the app store, they want $299 for the upgrade. This doesn't seem right. Isn't there a free upgrade that's compatible? Or am I screwed and have to pay for another version of FCP?

iPhone 4S, iOS 5.0.1, iPad 2 and Macbook Pro

Posted on

Reply
Question marked as Solved
Answer:
Answer:

While it is true that you require the latest FCP X, 10.3.4.

You do not need to purchase it again.

Make sure you sign in with your original I.D. details for the App Store when you first bought FCP X.


Al

Posted on

Question marked as Solved

Dec 11, 2017 10:45 PM in response to revnquads In response to revnquads

While it is true that you require the latest FCP X, 10.3.4.

You do not need to purchase it again.

Make sure you sign in with your original I.D. details for the App Store when you first bought FCP X.


Al

Dec 11, 2017 10:45 PM

Reply Helpful
User profile for user: revnquads

Question: Final Cut Pro won't work with High Sierra