Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: itunes 12.1.3.6 on windows 7 is not compatible with iphone 6s 11.1.2 OS version?

I am on windows 7 64 bits and installed itunes version 12.1.3.6

Trying to connect my iphone version 11.1.2. Getting message "iphone cannot be used because it requires a newer version of itunes.

I checked online, this is the latest version of itunes.

Can anyone suggest a solution?

iPhone 6s, iOS 11.1.2

Posted on

Reply
Question marked as Apple recommended
Answer:
Answer:

iTunes 12.1.3.6 is not the latest Version of iTunes.

Go here and download the latest version

iTunes - Download iTunes Now - Apple

Posted on

Dec 12, 2017 4:23 AM in response to vmaini1 In response to vmaini1

iTunes 12.1.3.6 is the last version that runs on Windows XP SP3 and Vista. You need iTunes 12.6.3.6 or better for iOS 11. If you have any trouble installing it from the link given above see Troubleshooting issues with iTunes for Windows updates for further advice.


tt2

Dec 12, 2017 4:23 AM

Reply Helpful (1)
User profile for user: vmaini1

Question: itunes 12.1.3.6 on windows 7 is not compatible with iphone 6s 11.1.2 OS version?