Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: App Store not working

I am a Romanian diplomat recently posted in Albania (Country which is not on the apple support list). I came here with my iMac 5k late 2015. Recently I updated to High Sierra and since the App Store does not work anymore. I tried everything. Sometimes, after I clean the Ram or change the country region it opens but still without the buttons on the upper bar (featured, purchases, upgrades). When I manage to open it, I turn on system preferences and click the update button and that opens my update page but I can not update any application. I don't know what to do anymore. Please help!

IMAC (RETINA 5K, 27-INCH, LATE 2015), macOS Sierra (10.12.5)

Posted on

Reply

Dec 13, 2017 8:41 AM in response to den.thed In response to den.thed

Thanks! Now, that can work, but how do I do app store to work as I am concerned altogether about app store not working. It that a known issue? Has it something to with my latest update? (All that happened after updating to 10.13.2), should I try re-installing this last update? (I do have a fusion drive iMac - can that be the problem?) - as I also own a macbook pro mid 2014 all SSD and on that computer app store works fine.


Thanks for the help!

Dec 13, 2017 8:41 AM

Reply Helpful

Dec 13, 2017 8:53 AM in response to taff89 In response to taff89

The 10.13.2 Combo Update can fix a lot of system problems including a bad standalone 10.13.2 updated from the Mac App Store.


macOS High Sierra 10.13.2 Combo Update


Simply Download and Install the High Sierra 10.13.2 Combo Update over the top of the current 10.13 version, then see if you are able to access the Mac App Store for additionally App updates.

Dec 13, 2017 8:53 AM

Reply Helpful

Dec 13, 2017 2:32 PM in response to taff89 In response to taff89

It still doesn't work. Now, by searching the net for solutions I stumbled on a page: https://www.imore.com/how-downgrade-macos


Somewhere at the bottom of the page, there is an article:

Having problems with file sharing after installing the macOS High Sierra 'root' Security Update? Here's the fix!


Somewhere there they give a solution through Terminal. I tried that as well, but I get this message:

iMac:~ THN$ /usr/libexec/configureLocalKDC

Error: configureLocalKDC needs to be run by root


So my question is - there is something wrong with my root, why can't I access it through terminal, maybe the problem starts from there?

Dec 13, 2017 2:32 PM

Reply Helpful
User profile for user: taff89

Question: App Store not working