Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Moderate-sized template causing system overload on high-spec iMac

Hi All,


I've recently set up a moderate sized template in Logic (227 tracks) for orchestral composition. I use instruments from EXS24, NI Komplete Ultimate 11 and Sample Modeling (listed below). I have saved this as a template in Logic. There are no audio tracks in my template - all midi.


However, after recording midi on only 5 tracks in a piece that lasts less than 2 minutes, I'm already getting system overload messages. My machine is recent and high end spec, so I wouldn't expect to be seeing these problems with such low load, but in an attempt to try to address this, and reduce CPU load, I have tried the following settings adjustments (not sure if some/all of these are helpful, but it hasn't resolved my problem):

1 - I/O buffer reduced from 128 to 256

2 - All tracks with no midi events at present turned off (leaving only 5 tracks not bypassed).

3 - All tracks with no midi events hidden

4 - 6 (of 8 available) processing threads selected

5 - Rewire Behavior - off


Anything obvious I'm missing here? I haven't yet frozen all tracks (as I understand it, I can only do this with tracks with EXS24 samples - I don't see the icon on NI tracks for example), but it seems unnecessary given that there is no midi data on these tracks, and they're hidden and bypassed? Also, the hardware spec should easily be able to cope with the very little I'm asking of it at the moment, no?


I really like the idea of using templates, but at the moment, it's not workable for me.

User uploaded file

Thanks for any help.


----------------------------

- Computer: IMac 27", 2017, 4.2GHz, i7, 32GB RAM & IMAC 27", late 2009, 2.8Gz i7, 8GB (linked via DisplayPort/thunderbolt connection only - not used for processing)

- DAW: Logic Pro X 10.3.2

- OS 10.3.2

- Sample Libraries: NI Komplete Ultimate 11, Sample Modeling Violin, Cello, Saxes, based on SWAM platform; Trumpet, Horn & Tuba v3, Trombone v3, Trumpet v3 in Kontakt

- Sound Card: Komplete Audio 6

- MIDI input devices: Komplete Kontrol s88 keyboard, StudioLogic midi keyboard, TEC Midi Breath/Bite controller, Leap Motion controller

- Control Surface: Behringer Xtouch

Posted on

Reply
Question marked as Helpful

Dec 13, 2017 4:48 PM in response to gh242 In response to gh242

Preferences/Audio Set Multithreading to "Playback Tracks"

Are you running a Retina screen? If so, with Logic closed go to Applications, single click the Logic app and get info... try setting Logic to open in Lo-res mode.

Use either 4 cores or 8 cores. (try 4 first)

Question marked as Helpful

Dec 14, 2017 10:09 AM in response to gh242 In response to gh242

****, one or a combination of those usually work, 4 cores same problem eh. Cutting down to half the available cores eliminates the hyper threading as you're running the 4 physical cores.


One last question: Are you using a high sample rate, 88.2 or 96kHz? If so I'm thinking that must be it.

There’s more to the conversation

Read all replies
Question marked as Helpful

Dec 13, 2017 4:48 PM in response to gh242 In response to gh242

Preferences/Audio Set Multithreading to "Playback Tracks"

Are you running a Retina screen? If so, with Logic closed go to Applications, single click the Logic app and get info... try setting Logic to open in Lo-res mode.

Use either 4 cores or 8 cores. (try 4 first)

Dec 13, 2017 4:48 PM

Reply Helpful (1)

Dec 13, 2017 4:52 PM in response to Pancenter In response to Pancenter

Many thanks - very helpful, but unfortunately didn't solve the problem 😟


Yes, I'm running a retina screen, but implementing all above (low res, 8 cores, and multithreading to playback tracks), but still getting system overload error. Grrr....

Dec 13, 2017 4:52 PM

Reply Helpful
Question marked as Helpful

Dec 14, 2017 10:09 AM in response to gh242 In response to gh242

****, one or a combination of those usually work, 4 cores same problem eh. Cutting down to half the available cores eliminates the hyper threading as you're running the 4 physical cores.


One last question: Are you using a high sample rate, 88.2 or 96kHz? If so I'm thinking that must be it.

Dec 14, 2017 10:09 AM

Reply Helpful (1)

Dec 14, 2017 10:15 AM in response to Pancenter In response to Pancenter

Again, great suggestion, but alas, my issue continues...


I'm running at 44.1KHz. I even turned the I/O buffer up to 512, and still no luck 😟 I also tried setting up an empty audio track, and selecting this during playback, but it doesn't help - I even froze this empty audio track - arrgghh this is so infuriating!


Is there anything in Kontakt I should be tweaking, as opposed to Logic? In my 227 track template, there are many instances of Kontakt, and I haven't optimised anything there - any suggestions?


Also, I'm using Sample Modeling - any optimisations I should try?


Last thing - when I set up a track in Kontakt, I select Multi-output 16xstereo. I do this out of ignorance of the correct setting, rather than preference. Would it help if I set everything to stereo instead? If so, is there an easy way of doing this across a large number of tracks, or do I need to go individually?


Thanks again - much appreciate the help.

Dec 14, 2017 10:15 AM

Reply Helpful

Dec 14, 2017 10:18 AM in response to gh242 In response to gh242

One more thing to add, in case it gives any clues to the problem: I've noticed that lately when I quit Logic, it takes a long time to close down: the user interface quits immediately, but it takes around a minute for the CPU meter window to disappear and for logic no longer to appear when I command-tab. If I go to the force quit window, I still see it. It eventually closes down after a minute or so, but it's new behaviour I haven't seen before, so thought I'd mention it in case it might help diagnose the problem.


Thank you for reading.

Dec 14, 2017 10:18 AM

Reply Helpful

Dec 14, 2017 3:18 PM in response to gh242 In response to gh242

Kontakt should not be using it's internal memory server, that should be disabled, the operating system now handles those chores. If it is enabled that could be part of the problem.


Does your Interface use a driver? If it's the latest, I'd try a previous driver, if it's not the latest...update it.


I hate USB! It's letting the operating system manage a real time function, and Apple's latest OS are not that great at real-time. Plus it uses processor cycles.

Dec 14, 2017 3:18 PM

Reply Helpful

Dec 14, 2017 11:32 PM in response to Pancenter In response to Pancenter

In Kontakt, the setting 'CPU overload protection' is disabled by default, and I haven't enabled it (is this what you're referring to?). Multiprocessor support is set to 8 cores.


The driver for my sound card (Komplete Audio 6) hasn't been updated since 2011, so I doubt it's that.


I was able to get playing again by reducing the number of tracks in my template substantially, down from 227 to 140. The more I read, the more it seems that I shouldn't be surprised that I'm running into these problems, despite a high spec machine - using a moderately large template seems to require either a slave system setup, and/or use of something like VEPro (for anyone else having these problems, an overview of VEPro and why it's needed for large templates was helpful: HOW TO: Vienna Ensemble Pro FX - YouTube). However, at 285 Euros, I don't think that's the route I'm going down, as I feel like I'm doing more tech and less music lately. Reducing the number of tracks has allowed me to get back to writing music, so that'll have to do for now. That said, I'm probably only able to do that because I implemented all the helpful suggestions from Pancenter's comments, so huge thanks to you for that - hopefully the thread helps others too.


Thanks again, you really helped.

Dec 14, 2017 11:32 PM

Reply Helpful

Jan 9, 2018 12:31 PM in response to gh242 In response to gh242

I am finding the same with a mid-2015 MBP quad-core i7@2.8Ghz. Ever since this patch to remediate the Meltdown and Spectre CPU security issues.


I have an unpatched 2014 MBP that does not have these issues. I won't be patching it – I've removed it from the network.

Jan 9, 2018 12:31 PM

Reply Helpful
User profile for user: gh242

Question: Moderate-sized template causing system overload on high-spec iMac