Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Itunes RSS Feed

I made a podcast

https://s3.ca-central-1.amazonaws.com/montrealpodcast000/VOR12.5.2017.mp3

Uploaded an image

https://s3.ca-central-1.amazonaws.com/montrealimage/Montreal.jpg

Generated an RSS Feed

Montreal Podcast


The feed passed in Cast Feed Validator but won't work in itunes. I got a message asking for "Explicit" and "Category" which I added thusly...

<itunes:explicit>YES</itunes:explicit>

<itunes:categorytext="Humour">

</itunes:category>

between

</image>

and

<item>


Now it won't validate and Apple still doesn't like it.


Very frustrating and as I know nothing about computers and coding I thought I'd post here.


Everything I've done so far I've just figured it out as I go - don't let my use of technical terms trick you into thinking I know what I'm talking about.

Please explain in plaiin English as if you were speaking to an imbecile. Ahem:)


Any help would be appreciated.

Posted on

Reply

Dec 13, 2017 11:38 PM in response to stevefrombrome In response to stevefrombrome

The situation is the same for me as when I answered your previous thread (no need to start a new thread - just add to the existing one, otherwise it gets confusing).


In Firefox, my default RSS reader, I get the error message I quoted before. CastFeedValidator and Feedvalidator can't find the file, neither can iTunes. Podbase sees a file but not as a feed. At the moment I can't get Podcasts Connect to load at all, but doubtless it will either not find the file or try to validate the error message/


I can only suggest you take this up with Amazon or try to find another host.

Dec 13, 2017 11:38 PM

Reply Helpful

Dec 14, 2017 8:52 AM in response to Roger Wilmut1 In response to Roger Wilmut1

The issue is with the code in the RSS Feed - was just hoping someone on here could quickly point out the issue. Thanks for trying to help. I'm so un-techy I couldn't even find the old post. Sorry!


The RSS Feed works fine and I found an itunes-friendly validator that pointed out 4 errors - unfortunately the 4 errors are greek to me - so I was hoping to find someone who could translate....


Sorry

This feed does not validate.

Dec 14, 2017 8:52 AM

Reply Helpful

Dec 14, 2017 9:02 AM in response to stevefrombrome In response to stevefrombrome

I still get the same result with the URL you posted:


https://s3.ca-central-1.amazonaws.com/thirdrssfee/feed.xml


thinking it perhaps has a typo I tried:


https://s3.ca-central-1.amazonaws.com/thirdrssfeed/feed.xml


which doesn't work either ('no such bucket'). If you are able to get a validator to recognize it I suspect we aren't talking about the same URL, so perhaps you could confirm it.


In the meantime, as to the errors you quote above, your link tags are empty:


<link />


they must contain the URL of your related web page:


<link>URL OF PAGE</link>


And within the 'enclosure' tag there is a "length" attribute which must contain the filesize in bytes (no commas).

Dec 14, 2017 9:02 AM

Reply Helpful

Dec 14, 2017 9:38 AM in response to Roger Wilmut1 In response to Roger Wilmut1

https://s3.ca-central-1.amazonaws.com/thirdrssfee/RSS+Feed+Montreal+Podcast+Vers ion+4.xml


I just copied and pasted into a chrome browser and it worked. I also double checked the other 2.


I don't have a website (just an mp3 podcast) so can I just remove the reference to the url?

Dec 14, 2017 9:38 AM

Reply Helpful

Dec 14, 2017 10:18 AM in response to stevefrombrome In response to stevefrombrome

I'm still getting exactly the same results. Here's my guess as to what is happening: you haven't made the files public. As you are signed into Amazon, everything works for you; but for anyone else who obviously isn't signed into your account, the files aren't accessible. The obvious next step would be for you either to sign out and try again, or ask a friend to check it on his computer.


I would think that if you removed the 'link' URL you might get away with it, but it's possible that the Store (which would display it) will complain. Try using the feed URL.

Dec 14, 2017 10:18 AM

Reply Helpful

Dec 14, 2017 10:34 AM in response to stevefrombrome In response to stevefrombrome

So I made a new feed copying a valid NYT sample I found online - I copy and paste to my browser and the link works fine but when I use Apple's recommended feed validator (W3C) it gives me the message:

Server returned HTTP Error 404: Not Found

Sorry

An error occurred while trying to validate this feed.

Possible causes:

  1. The address may be incorrect. Make sure the address is spelled correctly. Try loading the feed directly in your browser to make sure a feed exists at that address.
  2. The feed may be temporarily unavailable. The server may be down, or too slow. Try again later.
  3. The validator may be busted. If the feed exists, the server is fine, and the problem is reproducible, let us know on the feedvalidator-users mailing list.

It's frustrating because I can't tell if there is really a problem with my feed or if AWS is the problem - I have written specific permissions in all buckets so they are open to the public and when I test them they all work for me. Can't wait to figure this all out so I can get going...

Dec 14, 2017 10:34 AM

Reply Helpful

Dec 14, 2017 11:19 AM in response to stevefrombrome In response to stevefrombrome

The easy way to test it is to subscribe manually in iTunes (from the 'File' menu). When I do this it can't find the file. Similarly FeedValidator can't find it. The error message I quoted originally is what arises in a browser, and looks to me like Amazon saying either there is no file or that I don't have permission to access it. Why you are getting Feedvalidator to read it I don't know. I don't know how Amazon's facility for public access works, but it may be working for you because you are signed in. That's all I can suggest (other than finding another host - most ordinary web hosting services will work and won't cause the logging in problem). You could take it up with Amazon.

Dec 14, 2017 11:19 AM

Reply Helpful
User profile for user: stevefrombrome

Question: Itunes RSS Feed