Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Issues after updating to ios 11.2.1

I have noticed some issues after updating to 11.2.1 last night.


Carplay no longer works. When I plug the phone in the screen on my car now just says connecting to usb device rather than initiating carplay.


Also when playing music, I have no way now of knowing if shuffle is on or off. It does not highlight the button when pressed.



Anyone else seeing wither of these`?


Thanks,


J

iPhone X, iOS 11.2.1

Posted on

Reply

Dec 15, 2017 7:38 AM in response to KickingupDust In response to KickingupDust

Hey KickingupDust,

I understand that you are having some issues with CarPlay and while playing music you are unable to tell if shuffle is turned on, as it is not highlighted when you press the button. I can understand the concern. I'll be happy to help.

For the CarPlay issue, please review the following information from the article, Set up CarPlay with your iPhone :

Get help

If CarPlay doesn't work like you expect, here’s what you can check. After each step, try using CarPlay again.

  1. Make sure that Siri is turned on.
  2. Restart your iPhone and your car. Depending on your car, you might see the CarPlay Home screen when you turn it on. If you don't, look for the CarPlay logo on your car’s display.
  3. If possible, connect your iPhone to a different USB port in your car.
  4. Try a different Lightning to USB cable. Make sure that the cable is certified.
  5. Update to the latest version of iOS.
  6. Check your car’s manual for help. You might need to install firmware updates for your stereo.
For your shuffle issue, can I please have you force close the Music app and try to shuffle with a different playlist if possible.

Let me know how these steps go.

Warm Regards.

Dec 15, 2017 7:38 AM

Reply Helpful

Dec 15, 2017 8:26 AM in response to KickingupDust In response to KickingupDust

Thanks for getting back to us, KickingupDust, and letting us know that the CarPlay issue seems to be resolved. When you go to use shuffle, how are you going about it? Are you in a specific playlist, or are you attempting to use it from the Artists, Albums or Songs section of the Library in the Music app?

If you tap the Shuffle icon once, that should turn on the shuffle feature. If you happen to be tapping the Shuffle icon that is towards the top beside the Play icon, even though you tap it, it doesn't highlight in red as being turned on. If you swipe up from the bottom to view the Now Playing screen and then scroll down some, you will be able to see that Shuffle icon highlighted in red if it is on.

Open Now Playing on your iPhone, iPad, iPod touch, or Android phone

Let me know if this works out for you.

Dec 15, 2017 8:26 AM

Reply Helpful

Dec 20, 2017 3:09 PM in response to KickingupDust In response to KickingupDust

I can no longer use car play since updating to ios 11.1.2. The volume control doesn't work even if it starts to play a random track. I can't select tracks and if by chance it does play a track it disconnects if a traffic broadcast interrupts. A bloody disaster. The whole reason I bought a 32gb phone was to play all my music in the car. It worked perfectly on ios 10.

Dec 20, 2017 3:09 PM

Reply Helpful

Jan 2, 2018 10:37 AM in response to KickingupDust In response to KickingupDust

I have a 2017 Trax with AppleCar play, it worked just fine with it plugged into the USB port. I really enjoyed it. My phone updated to 11.2.1 and now NOTHING!! I took my phone into the local Apple store, NOTHING!! Same charging cable plugged into the wall charges just fine, so it’s not the cable! Apple please fix this!!

Jan 2, 2018 10:37 AM

Reply Helpful

Jan 9, 2018 3:36 PM in response to John_dun In response to John_dun

I had CarPlay issues as well, after updating from 11.2 to 11.2.1 on iPhone X - what solved it eventually was going back to 11.2 - I know 11.2.2 was just released, but I don’t see any reason to upgrade just yet. CarPlay works flawlessly via wireless in my 2018 BMW M4 on 11.2, and it was quite frustrating to reinstall my phone multiple times (even tried the 11.2.5 beta) until I found the solution in going back to 11.2.

Jan 9, 2018 3:36 PM

Reply Helpful

Jan 21, 2018 6:43 AM in response to PASGEN In response to PASGEN

Unfortunately I don't know. I have the iPhone X and maybe there is also a difference between BMW's and MB's software in terms of CarPlay. iOS 11.2 has been stable for me in the M4 but somebody from BMW told me that other customers were complaining about CarPlay issues and that a network reset helped these customers (which I think I hadn't tried but should've been done automatically when reinstalling iOS).

Jan 21, 2018 6:43 AM

Reply Helpful

Jan 21, 2018 9:21 AM in response to Markusm10 In response to Markusm10

Thanks for the info Markus. I seriously spoke with the MB garage and hope they'll push forward and get this solved.

When you reinstalled the iOS, did you restored the 11.2 version, I tried to do so but at the end, the phone forced me to install the 11.2.2 version, which is the most updated, even I had previously selected the 11.2 IPSW to begin the process.

Thanks again.

Jan 21, 2018 9:21 AM

Reply Helpful
User profile for user: KickingupDust

Question: Issues after updating to ios 11.2.1