Related Article

Update the firmware on your AirPort base station

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Problems updating to latest firmware

I got an error message when I tried to update to 7.7.9 for my base station. The message, which I admit I don't remember entirely, said that update failed. The device kept blinking amber – clearly unusable – so I unplugged it and restarted. Since then it has worked but I now lose connection on my Mac when I wake up from sleep. This is something that never occurred before. Wondering if anyone else has had any problems.


I have not been prompted to update my firmware since so it appears that the update worked. But weird getting the error message and now having the issues.

MacBook Pro (13-inch Mid 2012), iOS 11.2.1

Posted on

Reply

Dec 15, 2017 6:42 PM in response to Lance Wilcox In response to Lance Wilcox

Try reload the firmware again on the AirPort base station.


To do that, open AirPort Utility on your Mac

Hold down the option key on your Mac while you click on the actual version number of firmware

A drop down menu will appear with different firmware versions

Click on 7.7.9 and go through the update again


User uploaded file


If no luck, roll back the firmware to the previous version, 7.7.8, by following the steps above and choosing 7.7.8.

Dec 15, 2017 6:42 PM

Reply Helpful

Dec 24, 2017 7:53 AM in response to Lance Wilcox In response to Lance Wilcox

I am having the same issue. When I try to download the firmware update on my iPhone X it just crashes. Then after closing the app and reopening it it is there again with the red 1 beside it for the update. When I update it on my iMac it downloads it and then during the prepare install portion it fails and the message is, "An error occurred while updating the firmware -6,721".


Funny thing is, everything is working fine. WiFi works on everything, Philips Hue bridge, smart tv, 2 wifi connected plugs, PS4, xbox, all of my Apple hardware (watch, phone, iPad, iMac, MacBook pro). All im left with is this annoying amber blinking light that i didn't notice until last night and now I can't stop noticing it. But i don't want to unplug it because i don't want it to ruin everything. I don't really have a solution other than let it be because it seems to work.

Dec 24, 2017 7:53 AM

Reply Helpful

Dec 24, 2017 8:26 AM in response to rantinozzi06 In response to rantinozzi06

The amber light blinks to tell you that an update is available. If you don't want to be notified when an update is available.....so the amber light will not blink.....remove all of the check marks in AirPort Utility Preferences.


Open AirPort Utility

Click on the AirPort Utility menu item at the upper left corner of the screen

Click on Preferences

Remove all the check marks from the boxes

Close the window

Restart your Mac


User uploaded file


Then, do the same thing on the other Macs

Dec 24, 2017 8:26 AM

Reply Helpful

Dec 27, 2017 10:59 PM in response to Lance Wilcox In response to Lance Wilcox

Not sure if this will help you but it's worth a try.


I was experiencing the same problem of losing connection. I tried to update and got an error message.


I went back into Airport Utility and noticed my Apple ID password needed to be updated on my base station (see Back to My Mac option). After updating my password, I didn't experience any problems of losing connection. Hope this helps!

Dec 27, 2017 10:59 PM

Reply Helpful
User profile for user: Lance Wilcox

Question: Problems updating to latest firmware