Related Article

Use Messages on your iPhone, iPad, or iPod touch

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to stop messages that come on iPhone from showing up on iPad

How to keep messages from showing up an iPad that have been sent on iPhone

Posted on

Reply

Dec 18, 2017 11:38 AM in response to cook620 In response to cook620

Hey cook620!

Welcome to the Apple Support Communities. It sounds like you're concerned about messages appearing on multiple devices, so let me explain why that's happening and how to fix it. What you're seeing is expected behavior when two devices are sharing an Apple ID; along with messages, all sorts of other content can be shared between devices. It's a feature known as Continuity, and you can find all the details here: Use Continuity to connect your Mac, iPhone, iPad, iPod touch, and Apple Watch - Apple Support

This is intended as an ease-of-use feature for people with multiple devices, so they don't need to manually transfer content between devices when they switch from one to the other. Of course, if this is something you'd prefer didn't happen, you're welcome to head to Settings > Messages and make sure iMessage isn't logged into your Apple ID. In the event it's a Cellular + Wi-Fi model of iPad, you might also need to contact your carrier about blocking texts to that line.

I hope this helps you straighten things out. Let me know if you're still having trouble after logging out of the Apple ID and I'll keep working with you to figure out why. Cheers!

Dec 18, 2017 11:38 AM

Reply Helpful
User profile for user: cook620

Question: How to stop messages that come on iPhone from showing up on iPad