Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Lost Admin Privileges, Yes...This Problem Again

I simply tried to change the name of my iMac, had done in the past without problems.


This time it turned my Admin account into a "standard" account, so now I have no control, very frustrating.


I have looked up several articles about command + S and typed in some code to start a reboot in order to get the setup page like it's a new computer and add a "new user" as the admin. none of them worked. I also went to YT and the same thing, lots of how to vids and none of them work.


Can someone please tell me how to fix this idiotic problem? Lately, since Apple has released High Sierra there has been nothing but annoyances, and this seems to be one of them, they have patched the "root" problem so I can't use that anymore...what should I do?


Thanks!

iMac, iOS 9.0.1, updated to 10.10.5

Posted on

Reply

Dec 19, 2017 6:54 AM in response to resonator1six In response to resonator1six

There may be another way around this, but for sure if one of your accounts (and you should have several) if it were set to recover using Apple ID, then you could - see this user I am on right now has not had it enable.

User uploaded file


Have you gone into 'Recovery mode' from terminal

and used

""resetpassword"" ?!?

Dec 19, 2017 6:54 AM

Reply Helpful

Dec 19, 2017 8:52 AM in response to Mac_slide In response to Mac_slide

I was so frustrated by that I just went into Time Machine and restored it from a three day old archive.


It's now working fine and all the other "options" as mentioned above or in previous discussions did not work for me.

Dec 19, 2017 8:52 AM

Reply Helpful
User profile for user: resonator1six

Question: Lost Admin Privileges, Yes...This Problem Again