10 Replies Latest reply: Mar 7, 2007 2:59 AM by FocherAU
Toolshed4 Level 1 (25 points)
For next-to nothing I bought a PowerBook G4 17," thought to have a dead logic board. Imagine my surprise when this morning at an Apple Repair shop it was found merely to have a power cable disconnected from the logic board. When reconnected, my $250 parts laptop booted Tiger immediately. However, that euphoria had worn off because when I turned it on again at home, it booted into single user mode without being asked--and there it has stayed. It won't boot from disk and seemingly can't see the hard drive at all, so Open Firmware is where it stops in the boot process. Once there, I can either shut-down or mac-boot; the latter leads to ?Folder and FinderMan alternation and goes nowhere. I can eject cd to remove the (seemingly unbootable) disk, but /sbin/fsck -fy, diskutil verify /, and sudo root got me "unknown word" responses. The command prompt is 0>c and nothing else-- is this what the prompt should be before the system takes over? How do I get it to move beyond this point, to see there are boot options ahead?

MacBook Pro 2.0/2GB/100GB Mac OS X (10.4.8) PowerMac G4 FW800; PowerMac G4 Cube; PowerMac G3; Ti

MacBook Pro 2.0/2GB/100GB, Mac OS X (10.4.8), PowerMacs G4 FW800, Digital Audio Dual 533, Cube, AGP Graphics; PowerMac G3, TiBook G4
  • Michael Conniff Level 7 (33,125 points)
    You say it was able to boot to Tiger in the repair shop, so presumably you have a system on the internal disk.

    Looks like you've been unlucky. However, you say
    when I turned it on again at home, it booted into single user mode
    so Open Firmware is where it stops in the boot process
    These are contradictory, but I'm guessing the second is correct. Single User mode would be white text on a black screen, with a Unix prompt '#'. Open Firmware normally gives a '>' prompt.
    mac-boot; the latter leads to ?Folder and FinderMan alternation
    which means it can't find a bootable folder on any attached device.

    Can you boot in Target Disk Mode? See How to use FireWire target disk mode. If so, you could attach it to your MacBook, and carry out further trouble-shooting from there.
  • Toolshed4 Level 1 (25 points)
    I power on and am immediately in Open Firmware (it says Welcome to Open Firmware) black text on white with > prompt. It suggests "mac-boot" or "shut-down." the latters shuts it down; choosing boot changes the screen to grey with the alternating Question ?/Finder Man folders. Then, at least for the next 10 minutes, nothing happens (haven't waited longer than that). Doesn't boot into Target Disk Mode. When you try to boot from disk, it goes to Open Firmware; if you choose mac-boot again holding C, it foes to a Folder Finder Man on it and doesn't blink--which means it found a system and is booting--except nothing else happens (at least for the few minutes I have waited in the past. Am I just impatient?). I removed the hard drive and tested it in an enclosure--it's fine with an intact installation of OS X and replaced the case screws and it immediately booted into OS X. I updated the system , but upon restart it went straight back to Open Firmware. I think I need to designate a Start up disk. How do you do that from Open Firmware. Or in UNIX for that matter? Can I get to Unix from Open Firmware (I have X11 installed on all my machines)? As I am typing this, the PowerBook spontaneously began to boot into OS X but when it got to the point where the boot screen changes to the blue system, it restarted and went to Open Firmware.
  • Toolshed4 Level 1 (25 points)
    Thanks for the reference--that's exactly what's hasppening, but I've already tried to reset the PRAM and the Open Firmware without any in my issue. I now think I have identified a contributor to my problem if not the cause: the Option key on this PowerBook has been snapped off by some baby and is no longer fixed to the keyboard properly. I think all these key-stroke commands that require the Option key aren't succeeding because the key it self isn't working. They only reset that seems to have worked perfectly was resetting the NVRAM in Open Firmware because it was all text typing with no Option. Can you reset either the PRAM or the PMU from Open Firmware and if yes, how do you do it?

  • Michael Conniff Level 7 (33,125 points)
    Can you reset either the PRAM or the PMU from Open Firmware and if yes, how do you do it?
    I don't think you can. Depending on your model of Powerbook, you may be able to reset the PMU using the instructions here: Resetting PowerBook and iBook Power Management Unit (PMU). Several models have a button or switch for this.

    The only other thing I can suggest is a slight modification of the command sequence you previously tried: at the OF prompt type these three lines:


    The extra command my help, but I'm not that hopeful.
  • Michael Newbery Level 4 (2,395 points)
    It sounds to me like it can no longer find any device to boot off. Maybe another cable has come loose from the board.

    The http://www.firmworks.com/QuickRef.html page shows the OF commands to list the device tree. show-devs looks like a good place to start. Also, have you tried booting off an attached FireWire disk?

    MacPro 2.66, G4/466, eMac 800, iBook 1.33   Mac OS X (10.4.8)  

  • Toolshed4 Level 1 (25 points)
    I have tried to connect it to a properly functioning computer by FireWire/TDMode, but it wouldn't read. I should try again because it's condition has, overall, gotten better. It boots into OS X about half the time now and responds to certain commands (like resetting the NVRAM). However, any command requiring the Option key doesn't get executed--so I'm off to get an Option key installed right now. It was suggested at a Apple Repair pace the hard drive might be be but I put it into a titanium PowerBook and it read/functioned fine, although it had a million disk permissions to repair. Noticeably, the computer runs very hot after an hour of use. When it's cool or starting up from a period of shut down, it always boots correctly. When it's hot, it always go to Open Firmware. Two last things: the way I found out it wasn't dead was when a tech noticed a cable had been left disconnected when it was reassembled--another could be, although I haven't noticed any; more importantly, there's a Phillips screw still missing to the right of the RAM bay.
  • Toolshed4 Level 1 (25 points)
    The three-lines all after a single O> prompt? Hope so because that's what I did and it restarted0--into Open Firmware. Can I designate a start-up disk in Open Firmware? Would a bad PRAM battery cause it to forget which disk is the startup? it also regularly resets the date to December 21, 1969. I will decamp to the PowerBook sector after this to avid shifting the focus tpp much to hardware.

  • Michael Conniff Level 7 (33,125 points)
    it also regularly resets the date to December 21, 1969
    Don't you mean Dec 31? Resetting the PRAM can cause this to happen, as well as a bad battery. But if you suspect the battery, it would be worth getting a new one—they're cheap enough.
    Can I designate a start-up disk in Open Firmware?
    Yes, but it's not easy. I wouldn't recommend it.
  • FocherAU Level 1 (0 points)
    I have an iMac G5 20 inch (first version) with pretty much the same problem. The computer immediately dumps into the firmware and will not boot off the internal drive, a bootable CD/DVD, or in Target Mode off another iMac.

    The initial error is:

    Invalid memory access at %SRR0 0000000:ff848190 %SRR1 1000000:02003030

    Issuing a "mac-boot" gives the "ALLOC-MEM request too big!" message.

    I have done a reset-nvram, reset the PMU, tried to reset the PRAM (although I never get the second tone, so maybe that did not work). I tried swapping with known good RAM. I unplugged the AirPort card.

    I took the machine to an Apple repair facility. They said I need to replace the mainboard and gave a price estimate of $1000. Needless to say, I won't be doing that.

    I am amazed at the (still) glaring lack of technical information available for Macs on the web.

    iMac G5   Mac OS X (10.4.8)