Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: "Allow" Button in System Preferences for Blocked System Software Doesn't Work

Hi all,


I'm having severe difficulties in getting my Roland A49 keyboard to work on Mac OSX 10.13 on a MacBook Pro 13-Inch Mid 2012 Model.


I have downloaded the latest drivers for the keyboard from the Roland website and installed as per the instructions (https://www.roland.com/global/support/by_product/a-49/updates_drivers/d3f5e60c-3 c95-4a50-8263-24fea58c6355/)


After restarting I receive the error in System Preferences that "System software from developer "Roland Corporation" was blocked from loading". As per the instructions on the website I clicked "Allow".... however when I do so absolutely NOTHING happens.


I have read around online and found that a common problem with the "Allow" button not working here is if you are using some sort of 3rd party software to emulate mouse clicks (such as remote connecting with VNC, TouchPerf, etc.). However I have none of the above. I am using the trackpad directly on the MacBook with no other clicking software enabled. I have also tried connecting an Apple Mouse, which also did nothing.


Here are some links I have been reading about this topic. Unfortunately none of them help my situation:


https://helpcenter.graphisoft.com/technotes/operating-systems/macos-10-13-high-s ierra/system-extension-blocked-warning-during-installation-of-archicad-on-macos- 10-13-high-sierra/


"Allow" button in System Preferences does not work · Issue #1017 · tekezo/Karabiner-Elements · GitHub


How to Fix Extensions Blocked by Gatekeeper in macOS 10.13 High Sierra - Plugable


For the record I have also tried the other basic troubleshooting things: restarting, uninstalling and reinstalling the driver, installing an earlier version of the driver (intended for MacOSX 10.9), pressing the allow button with the keyboard plugged in and unplugged, etc. I have also tried this trick from Roland I found on Sweetwater, which briefly gets the lights on the keyboard to appear, but it is still not recognised:


https://www.sweetwater.com/sweetcare/articles/my-roland-a49-wont-connect-to-my-c omputer/


No luck whatsoever. Any help would be greatly appreciated.


Regards,


Tim H

MacBook Pro, macOS High Sierra (10.13.2), Roland A49

Posted on

Reply

Page content loaded

Feb 7, 2018 1:56 AM in response to ClairvauxMac In response to ClairvauxMac

Had the same problem for a long time but I accidentally solved it. I'm normally using a Wacom tablet and clicking "allow" with the pen didn't work. But then, for some reason, I clicked it with my mouse and it worked!


I've had similar experiences with at least Google Chrome browser when using Google Drive. The pen clicks just didn't register... But using a good old wired mouse did the trick.

Feb 7, 2018 1:56 AM

Reply Helpful (1)

Mar 30, 2018 7:55 PM in response to ClairvauxMac In response to ClairvauxMac

I had to disable "Switch" . Others have had to click "Allow" with their Apple mouse or Trackpad, instead of their Wacom tablet or 3rd party mouse. Any other running utilities might be causing clicks to be intercepted, so disable everything until it works - that includes Slack, MagicPrefs, xGestures, etc

Mar 30, 2018 7:55 PM

Reply Helpful

Apr 17, 2018 12:06 AM in response to ClairvauxMac In response to ClairvauxMac

I had a similar problem when trying to install the Boom 2 app. I noticed that my guest account was still logged into. When I went into my guest account the security and privacy window was open. I clicked allow and it immediately closed out. When I logged back into my account the app I was trying to install had been installed. Hope this helps!

Apr 17, 2018 12:06 AM

Reply Helpful
User profile for user: ClairvauxMac

Question: "Allow" Button in System Preferences for Blocked System Software Doesn't Work