Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't connect scanner through USB-C in OS High Sierra

Hi,


I recently bought the Reflecta MF5000 scanner to scan my 120mm film negatives. I am using a Macbook pro laptop with the new USB-C ports but somehow I cannot get my software to connect to the scanner. I am using OX High Sierra and after contacting the manufacturer I was asked to try a direct USB-B to USB-C cable, instead of a 'normal' USB-B to USB-2 cable. As the USB-C to USB-2 adaptor might prohibit with a stable connection with the scanner. This did not work.


I have tried:

- installing different software, Cyberview x5, VueScan, SilverFast etc. All do not recognise the scanner.

- In my system overview, the OS does see a USB device as normal.

- I reinstalled the software, checked the connection in different ports, tried different cables(!)

- I reset the NVRAM.


The funny thing, when I tried the old mode USB-B to USB-2 cable on my iMac (running OS Sierra), it instantly worked. I can scan but I want to- at some point update this to High Sierra so...


Logic dictates it's because of the USB ports on my Macbook Pro but my Macbook DOES see a USB device when connecting any cables.


Has anyone experienced this? I am guessing some problem with the scanner drivers, or something deeper inside OS High Sierra. Any ideas anyone?


Greetings from Amsterdam.

MacBook Pro TouchBar and Touch ID, macOS High Sierra (10.13.2), USB-C ports

Posted on

Reply

Page content loaded

Feb 11, 2018 7:50 AM in response to guido250 In response to guido250

Also RPS 10M with me... here´s the reply from the Silverfast Support (German):


"Lieber xxxx,

leider kann ich da momentan nichts anderes raten als Geduld zu haben. Der OEM-Hersteller ergründet die Problematik gerade und wird ggf. einen angepassten Treiber zur Verfügung stellen. Bis macOS 10.12 fkt. es mit dem aktuellen via USB-C und ab 10.13 nur auf USB-A/B-Anschlüssen. "

Feb 11, 2018 7:50 AM

Reply Helpful
User profile for user: MatthijsU

Question: Can't connect scanner through USB-C in OS High Sierra