Related Article

How to upgrade to macOS Mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: I have a late 2008 MacBook. Does that mean I can't update it to macOS Sierra?

I have a late 2008 MacBook. Does that mean I can't update it to macOS Sierra?

Posted on

Reply

Feb 26, 2018 9:48 AM in response to pfei In response to pfei

How to get macOS Sierra - https://support.apple.com/HT201475 - including system requirements Looks like they changed it to HighSierra now 😐


Sierra system requirements:

iMac (Late 2009 and later)

MacBook (Late 2009 and later)

MacBook Pro (2010 and later)

MacBook Air (2010 and later)

Mac Mini (2010 and later)

Mac Pro (2010 and later)

Feb 26, 2018 9:48 AM

Reply Helpful
User profile for user: pfei

Question: I have a late 2008 MacBook. Does that mean I can't update it to macOS Sierra?